Bug 864131 - ValueError: raid1 requires at least 2 disks
ValueError: raid1 requires at least 2 disks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:cf781420b1ae23a923eb79731df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 12:43 EDT by Chris Murphy
Modified: 2012-11-15 09:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 09:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (251.02 KB, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: product (6 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: type (9 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: storage.log (131.54 KB, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: version (11 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: environ (761 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: anaconda.log (6.90 KB, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: syslog (62.94 KB, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: packaging.log (2.77 KB, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-08 12:43 EDT, Chris Murphy
no flags Details
File: release (24 bytes, text/plain)
2012-10-08 12:44 EDT, Chris Murphy
no flags Details
File: program.log (17.91 KB, text/plain)
2012-10-08 12:44 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-10-08 12:43:31 EDT
Description of problem:
1. Selected two disks.
2. Set redundancy for /boot
3. Set redudancy for /
4. Clicked on swap

Crash.


Version-Release number of selected component:
anaconda-18.12

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.12 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/mdraid.py", line 146, in get_member_space
:    % (level, min_members))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3290, in device_size
:    level=self.raid_level)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1850, in setContainerMembers
:    device_space = factory.device_size
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2036, in newDevice
:    members=members)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 774, in _replace_device
:    self.__storage.newDevice(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 888, in _save_right_side
:    selector=selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1534, in on_selector_clicked
:    self._save_right_side(self._current_selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 188, in _onSelectorClicked
:    cb(selector)
:ValueError: raid1 requires at least 2 disks
Comment 1 Chris Murphy 2012-10-08 12:43:34 EDT
Created attachment 623548 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-10-08 12:43:35 EDT
Created attachment 623549 [details]
File: product
Comment 3 Chris Murphy 2012-10-08 12:43:37 EDT
Created attachment 623550 [details]
File: type
Comment 4 Chris Murphy 2012-10-08 12:43:38 EDT
Created attachment 623551 [details]
File: ifcfg.log
Comment 5 Chris Murphy 2012-10-08 12:43:40 EDT
Created attachment 623552 [details]
File: storage.log
Comment 6 Chris Murphy 2012-10-08 12:43:42 EDT
Created attachment 623553 [details]
File: version
Comment 7 Chris Murphy 2012-10-08 12:43:52 EDT
Created attachment 623554 [details]
File: environ
Comment 8 Chris Murphy 2012-10-08 12:43:53 EDT
Created attachment 623555 [details]
File: anaconda.log
Comment 9 Chris Murphy 2012-10-08 12:43:55 EDT
Created attachment 623556 [details]
File: syslog
Comment 10 Chris Murphy 2012-10-08 12:43:56 EDT
Created attachment 623557 [details]
File: hashmarkername
Comment 11 Chris Murphy 2012-10-08 12:43:58 EDT
Created attachment 623558 [details]
File: packaging.log
Comment 12 Chris Murphy 2012-10-08 12:43:59 EDT
Created attachment 623559 [details]
File: cmdline_file
Comment 13 Chris Murphy 2012-10-08 12:44:01 EDT
Created attachment 623560 [details]
File: release
Comment 14 Chris Murphy 2012-10-08 12:44:03 EDT
Created attachment 623561 [details]
File: program.log
Comment 15 Chris Murphy 2012-10-08 13:00:55 EDT
Could be a duplicate of Bug 862667, however in that bug a single disk was reported. In this bug, two disks are available and selected. Exact sequence is:

1. Choose both disks.
2. Choose custom partitioning.
3. Choose "click here to create them automatically"
4. Boot is preselect, click customize and change Device Type to RAID, uncheck optimized performance, check redundancy.
5. Choose Root, click customize and change Device Type to RAID, uncheck optimized performance, check redundancy.
6. Click on Swap or click on Home

Result: Crash immediately upon clicking on either Home or Swap. Neither option highlights in blue first.

100% reproducible
Comment 16 Chris Murphy 2012-10-08 13:07:37 EDT
The UI allows me to set /boot to RAID 1, but the changes don't stick. I only get the crash if I start by setting /boot to RAID 1. If I set /home and / to RAID 1, then go to /boot or swap, I do not get a crash.
Comment 17 Dave Jones 2012-10-08 15:01:25 EDT
Was trying to create a RAID0 stripe of sda/sdb

It complained about there being insufficient disks. The UI was not obvious to me how to specify the 2nd disk to add as a member, so I clicked in the mount tree on the left, and got this traceback.


Package: anaconda-18.12
Architecture: i686
OS Release: Fedora release 18
Comment 18 David Lehman 2012-11-15 09:29:53 EST
This should have been fixed a long time ago. Please reopen if you're still seeing this with the latest F18 Beta TCs.

Note You need to log in before you can comment on or make changes to this bug.