Bug 864145 - SELinux is preventing /usr/sbin/logrotate from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
SELinux is preventing /usr/sbin/logrotate from 'write' accesses on the fifo_f...
Status: CLOSED DUPLICATE of bug 864143
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:980cfde1abdc36886b394a4d016...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 13:54 EDT by Nicolas Mailhot
Modified: 2012-10-09 04:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-08 13:54 EDT, Nicolas Mailhot
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-08 13:54 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2012-10-08 13:54:54 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.7.0-0.rc0.git2.4.fc19.x86_64

description:
:SELinux is preventing /usr/sbin/logrotate from 'write' accesses on the fifo_file /run/systemd/sessions/110.ref (deleted).
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If vous souhaitez ignorer que logrotate tente d'obtenir l'accès write à 110.ref (deleted) fifo_file car vous pensez qu'il ne devrait pas nécessiter cet accès.
:Then vous devriez rapporter ceci en tant qu'anomalie.  
:Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
:Do
:# grep /usr/sbin/logrotate /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If vous pensez que logrotate devrait être autorisé à accéder write sur 110.ref (deleted) fifo_file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep logrotate /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:logrotate_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_logind_sessions_t:s0
:Target Objects                /run/systemd/sessions/110.ref (deleted) [
:                              fifo_file ]
:Source                        logrotate
:Source Path                   /usr/sbin/logrotate
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           logrotate-3.8.3-1.fc19.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.7.0-0.rc0.git2.4.fc19.x86_64 #1
:                              SMP Fri Oct 5 20:59:24 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-08 03:22:04 CEST
:Last Seen                     2012-10-08 03:22:04 CEST
:Local ID                      101b2487-eaba-4a69-9d1a-f46141764693
:
:Raw Audit Messages
:type=AVC msg=audit(1349659324.737:8778): avc:  denied  { write } for  pid=7210 comm="logrotate" path=2F72756E2F73797374656D642F73657373696F6E732F3131302E726566202864656C6574656429 dev="tmpfs" ino=2143403 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349659324.737:8778): arch=x86_64 syscall=execve success=yes exit=0 a0=fb90a0 a1=fb80a0 a2=fb7ac0 a3=2 items=0 ppid=7207 pid=7210 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=110 tty=(none) comm=logrotate exe=/usr/sbin/logrotate subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: logrotate,logrotate_t,systemd_logind_sessions_t,fifo_file,write
:
:audit2allow
:
:#============= logrotate_t ==============
:allow logrotate_t systemd_logind_sessions_t:fifo_file write;
:
:audit2allow -R
:
:#============= logrotate_t ==============
:allow logrotate_t systemd_logind_sessions_t:fifo_file write;
:
Comment 1 Nicolas Mailhot 2012-10-08 13:54:57 EDT
Created attachment 623604 [details]
File: type
Comment 2 Nicolas Mailhot 2012-10-08 13:54:59 EDT
Created attachment 623605 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:18:34 EDT

*** This bug has been marked as a duplicate of bug 864143 ***

Note You need to log in before you can comment on or make changes to this bug.