Bug 864153 - SELinux is preventing /usr/bin/dbus-daemon from 'write' accesses on the fifo_file /run/systemd/sessions/1.ref.
SELinux is preventing /usr/bin/dbus-daemon from 'write' accesses on the fifo_...
Status: CLOSED DUPLICATE of bug 864143
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4d7bf03c45f00a9c215f464ea10...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 13:57 EDT by Nicolas Mailhot
Modified: 2012-10-09 04:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 04:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-08 13:57 EDT, Nicolas Mailhot
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-08 13:57 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2012-10-08 13:57:18 EDT
Additional info:
libreport version: 2.0.15
kernel:         3.7.0-0.rc0.git2.4.fc19.x86_64

description:
:SELinux is preventing /usr/bin/dbus-daemon from 'write' accesses on the fifo_file /run/systemd/sessions/1.ref.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If vous souhaitez ignorer que dbus-daemon tente d'obtenir l'accès write à 1.ref fifo_file car vous pensez qu'il ne devrait pas nécessiter cet accès.
:Then vous devriez rapporter ceci en tant qu'anomalie.  
:Vous pouvez générer un module de stratégie local pour dontaudit cet accès.
:Do
:# grep /usr/bin/dbus-daemon /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If vous pensez que dbus-daemon devrait être autorisé à accéder write sur 1.ref fifo_file par défaut.
:Then vous devriez rapporter ceci en tant qu'anomalie.
:Vous pouvez générer un module de stratégie local pour autoriser cet accès.
:Do
:autoriser cet accès pour le moment en exécutant :
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_logind_sessions_t:s0
:Target Objects                /run/systemd/sessions/1.ref [ fifo_file ]
:Source                        dbus-daemon
:Source Path                   /usr/bin/dbus-daemon
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           dbus-1.6.8-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-32.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.7.0-0.rc0.git2.4.fc19.x86_64 #1
:                              SMP Fri Oct 5 20:59:24 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-07 13:42:52 CEST
:Last Seen                     2012-10-07 13:42:52 CEST
:Local ID                      3826af54-1be4-4a26-b0f2-df85c9c1f5b5
:
:Raw Audit Messages
:type=AVC msg=audit(1349610172.883:62): avc:  denied  { write } for  pid=923 comm="dbus-daemon" path="/run/systemd/sessions/1.ref" dev="tmpfs" ino=20682 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_sessions_t:s0 tclass=fifo_file
:
:
:type=SYSCALL msg=audit(1349610172.883:62): arch=x86_64 syscall=execve success=yes exit=0 a0=4051fc a1=7fff4d3d0950 a2=7fff4d3d3038 a3=7fd77b998a10 items=0 ppid=922 pid=923 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=1 tty=(none) comm=dbus-daemon exe=/usr/bin/dbus-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,xdm_dbusd_t,systemd_logind_sessions_t,fifo_file,write
:
:audit2allow
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t systemd_logind_sessions_t:fifo_file write;
:
:audit2allow -R
:
:#============= xdm_dbusd_t ==============
:allow xdm_dbusd_t systemd_logind_sessions_t:fifo_file write;
:
Comment 1 Nicolas Mailhot 2012-10-08 13:57:22 EDT
Created attachment 623618 [details]
File: type
Comment 2 Nicolas Mailhot 2012-10-08 13:57:23 EDT
Created attachment 623619 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-09 04:19:30 EDT

*** This bug has been marked as a duplicate of bug 864143 ***

Note You need to log in before you can comment on or make changes to this bug.