Bug 864225 - cloud Resource cluster Names should trim extra white space at the beggining or end of an entry
cloud Resource cluster Names should trim extra white space at the beggining o...
Status: CLOSED DUPLICATE of bug 819789
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Angus Thomas
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 18:20 EDT by Shveta
Modified: 2012-11-27 23:36 EST (History)
3 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.24-1.el6cf.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 23:36:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
duplicate_cluster (56.98 KB, image/png)
2012-10-08 18:20 EDT, Shveta
no flags Details

  None (edit)
Description Shveta 2012-10-08 18:20:59 EDT
Created attachment 623789 [details]
duplicate_cluster

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Able to create duplicate clusters with same name by giving spaces at the beinning and at the end of the cluster.
2.
3.
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
aeolus-conductor-doc-0.13.16-1.el6cf.noarch
aeolus-conductor-daemons-0.13.16-1.el6cf.noarch
rubygem-aeolus-cli-0.7.3-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.16-1.el6cf.noarch
aeolus-conductor-0.13.16-1.el6cf.noarch
aeolus-configure-2.8.8-1.el6cf.noarch
Comment 2 Giulio Fidente 2012-11-15 09:01:02 EST
this is working with aeolus-conductor-0.13.24-1.el6cf.noarch , leading/trailing spaces are removed
Comment 3 Dave Johnson 2012-11-27 23:36:17 EST
Digging through bugs I retested this and found it is still valid with v1.1 release... BUT its a duplicate


conductor=> select * from frontend_realms;
 id |  name  | lock_version |         created_at         |         updated_at         | description 
----+--------+--------------+----------------------------+----------------------------+-------------
  1 |  dave  |            0 | 2012-11-28 04:24:11.518261 | 2012-11-28 04:24:11.518261 | 
(1 row)

conductor=> select * from frontend_realms where name='dave';
 id | name | lock_version | created_at | updated_at | description 
----+------+--------------+------------+------------+-------------
(0 rows)

conductor=> select * from frontend_realms where name=' dave ';
 id |  name  | lock_version |         created_at         |         updated_at         | description 
----+--------+--------------+----------------------------+----------------------------+-------------
  1 |  dave  |            0 | 2012-11-28 04:24:11.518261 | 2012-11-28 04:24:11.518261 | 
(1 row)

conductor=> \q
[root@qeblade37 ~]# rpm -qa | grep conductor
aeolus-conductor-0.13.24-1.el6cf.noarch
aeolus-conductor-doc-0.13.24-1.el6cf.noarch
aeolus-conductor-daemons-0.13.24-1.el6cf.noarch

*** This bug has been marked as a duplicate of bug 819789 ***

Note You need to log in before you can comment on or make changes to this bug.