Bug 864275 - RFE: upload/download txt, DTD and OpenDocument through web interface
RFE: upload/download txt, DTD and OpenDocument through web interface
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: David Mason
Alex Eng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-08 23:20 EDT by David Mason
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: Zanata version 2.0.3-SNAPSHOT (20121127-1451)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Mason 2012-10-08 23:20:57 EDT
Description of problem:
Implement upload and download through the web UI for documents of type DTD, plain text (.txt), and Open Document Format (odt, ods, odp, etc.).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Only .po and .pot can be uploaded through the web UI.

Expected results:
Able to upload formats listed above.

Additional info:
Comment 1 Ding-Yi Chen 2012-10-15 22:13:29 EDT
Tested with Zanata version 1.8.0-SNAPSHOT (20121015-1310)

1. After I click Download as text link, Firefox shows File not found; and
2. The Content-Type of Download as po link is application/octet-stream, which should be text/plain

Reassigned.
Comment 2 David Mason 2012-11-12 22:13:35 EST
po link is not part of this feature, so should be filed as a separate bug. Filed as https://bugzilla.redhat.com/show_bug.cgi?id=876012
Comment 3 David Mason 2012-11-12 22:21:08 EST
Checked download of text and odt files in both Firefox and Chrome and both worked for me. The reported "File not found" may just be due to some stale data on a test machine. Returning to QA to check.
Comment 4 Alex Eng 2012-11-27 19:59:22 EST
Verified in Zanata version 2.0.3-SNAPSHOT (20121127-1451).

Note You need to log in before you can comment on or make changes to this bug.