Bug 864294 - [abrt] yum-3.2.29-4.fc15: re.py:245:_compile:error: bad character range
[abrt] yum-3.2.29-4.fc15: re.py:245:_compile:error: bad character range
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:78563bbfca6d385077da6c473a5...
:
: 866083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 00:19 EDT by maurizio
Modified: 2014-10-09 04:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-09 04:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maurizio 2012-10-09 00:19:06 EDT
abrt version: 2.0.1
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/yum remove ::19:a8af:a0d0:7508:139a:a8af.fwb ::19:a8af:a0d0:7508:139a:a8af.jpg '[8118-9pcv11_-31.db-journal]Lord Jesus christ .jpg' cpp.pap d158:608:2c5f:908::10:3809.fwb ::d158:608:2c5f:908::10:3809.jpg d158:608:2c5f:908::f0:5008.fwb d158:608:2c5f:908::f0:5008.jpg jesus.bat cheese
component:      yum
executable:     /usr/bin/yum
kernel:         2.6.38.6-26.rc1.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        yum-3.2.29-4.fc15
reason:         re.py:245:_compile:error: bad character range
time:           Sun Sep 23 18:43:13 2012
uid:            0
username:       root

backtrace:
:re.py:245:_compile:error: bad character range
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 267, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 120, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 432, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/yumcommands.py", line 413, in doCommand
:    return base.erasePkgs(extcmds)
:  File "/usr/share/yum-cli/cli.py", line 823, in erasePkgs
:    rms = self.remove(pattern=arg)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 3825, in remove
:    (e,m,u) = self.rpmdb.matchPackageNames([kwargs['pattern']])
:  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 286, in matchPackageNames
:    specs[p] = re.compile(restring)
:  File "/usr/lib/python2.7/re.py", line 190, in compile
:    return _compile(pattern, flags)
:  File "/usr/lib/python2.7/re.py", line 245, in _compile
:    raise error, v # invalid expression
:error: bad character range
:
:Local variables in innermost frame:
:cachekey: (<type 'str'>, '[8118-9pcv11_-31.db-journal]Lord\\ Jesus\\ christ\\ \\.jpg\\Z(?ms)', 0)
:pattern: '[8118-9pcv11_-31.db-journal]Lord\\ Jesus\\ christ\\ \\.jpg\\Z(?ms)'
:p: None
:flags: 0
:key: ('[8118-9pcv11_-31.db-journal]Lord\\ Jesus\\ christ\\ \\.jpg\\Z(?ms)', 0)
:v: error('bad character range',)
Comment 1 Zdeněk Pavlas 2012-10-15 02:59:56 EDT
*** Bug 866083 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.