Bug 864305 - Update project page code return unexpected error
Update project page code return unexpected error
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 01:12 EDT by Alex Eng
Modified: 2012-10-14 20:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 20:05:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Eng 2012-10-09 01:12:28 EDT
Description of problem:
Unexpected error returned after save in project page code

Version-Release number of selected component (if applicable):
2.0

How reproducible:
Always


Steps to Reproduce:
1. Go to any project page
2. Click "Edit Page Code" on right menu
3. Make changes in the text area and click save.
  
Actual results:
Unexpected error page return
Comment 1 Alex Eng 2012-10-09 02:13:04 EDT
Exception only happens if user copy and paste string from browser. Typing in the text area does not trigger any problem.

Caused by: java.lang.RuntimeException: line 1:1: unexpected char: 0xFEFF
	at org.jboss.seam.ui.component.UIFormattedText.getFormattedText(UIFormattedText.java:66)
	at org.jboss.seam.ui.renderkit.FormattedTextRendererBase.doEncodeBegin(FormattedTextRendererBase.java:24)
	at org.jboss.seam.ui.util.cdk.RendererBase.encodeBegin(RendererBase.java:79)
	at javax.faces.component.UIComponentBase.encodeBegin(UIComponentBase.java:813)
	at org.jboss.seam.ui.util.cdk.RendererBase.renderChild(RendererBase.java:184)
	at org.jboss.seam.ui.util.cdk.RendererBase.renderChildren(RendererBase.java:166)
	at org.jboss.seam.ui.util.cdk.RendererBase.renderChild(RendererBase.java:188)
	at org.jboss.seam.ui.util.cdk.RendererBase.renderChildren(RendererBase.java:166)
	at org.jboss.seam.ui.renderkit.DecorateRendererBase.doEncodeChildren(DecorateRendererBase.java:152)
	at org.jboss.seam.ui.util.cdk.RendererBase.encodeChildren(RendererBase.java:92)
	at javax.faces.component.UIComponentBase.encodeChildren(UIComponentBase.java:837)
	at javax.faces.component.UIComponent.encodeAll(UIComponent.java:930)
	at javax.faces.component.UIComponent.encodeAll(UIComponent.java:933)
	at com.sun.facelets.FaceletViewHandler.renderView(FaceletViewHandler.java:592)
	at org.ajax4jsf.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:100)
	at org.ajax4jsf.application.AjaxViewHandler.renderView(AjaxViewHandler.java:176)
	at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:110)
	at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:100)
	at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:266)
	... 55 more
Caused by: line 1:1: unexpected char: 0xFEFF
	at org.jboss.seam.text.SeamTextLexer.nextToken(SeamTextLexer.java:230)
	at antlr.TokenBuffer.fill(TokenBuffer.java:69)
	at antlr.TokenBuffer.LA(TokenBuffer.java:80)
	at antlr.LLkParser.LA(LLkParser.java:52)
	at org.jboss.seam.text.SeamTextParser.startRule(SeamTextParser.java:538)
	at org.jboss.seam.ui.component.UIFormattedText.getFormattedText(UIFormattedText.java:59)
	... 74 more

Note You need to log in before you can comment on or make changes to this bug.