This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 86437 - Glibc update breaks wine
Glibc update breaks wine
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 87569 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-21 17:53 EST by drew.middlesworth
Modified: 2007-04-18 12:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 15:21:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drew.middlesworth 2003-03-21 17:53:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
Wine does not run after installing the glibc update

Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80

How reproducible:
Always

Steps to Reproduce:
1. install glibc update
2. type wine at a console
    

Actual Results:  wine: relocation error: /usr/lib/wine/libntdll.dll.so: symbol
__fork, version GLIBC_2.0 not defined in file libc.so.6 with link time reference


Expected Results:  no error
Comment 1 John Wells 2003-03-24 14:42:13 EST
Seeing this as well.  Has broken quite a bit of which relies on wine locally. 
Currently downloading src rpm to see if that'll do the trick.
Comment 2 Jakub Jelinek 2003-03-26 12:49:06 EST
Can you please try ftp://people.redhat.com/jakub/glibc/errata/8.0/ ?
Comment 3 Harold Campbell 2003-03-27 23:26:03 EST
I've observed two problems with wine since the glibc upgrade. The first had to
do with lstat()ing the wineserver socket. That one is fixed by your newer
packages. The second, which shows up with Half-Life for me, is:

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 6175 requests (6147 known processed) with 0 events remaining.

This pops up anywhere from just after the main menu starts drawing to right
after clicking a menu option. This is not fixed by your newer packages.
Comment 4 Jakub Jelinek 2003-03-29 03:59:27 EST
Can you please try ftp://people.redhat.com/jakub/glibc/errata/8.0/*4.80.3* ?
4.80.1 was still using only /lib libs, not /lib/i686 and thus non-FLOATING_STACKS
libpthread.
Comment 5 Douglas Bollinger 2003-03-30 08:46:05 EST
I have the exact same problem as the other posters.

I tried the latest glibc that you offered at comment #4 and I still have the
problem, wine won't work:

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 169 requests (169 known processed) with 0 events remaining.
Comment 6 Thomas Woerner 2003-03-31 08:28:35 EST
*** Bug 87569 has been marked as a duplicate of this bug. ***
Comment 7 drew.middlesworth 2003-03-31 12:30:43 EST
glibc 2.3.2-4.80.3 works for me, fixes the problem
Comment 8 Steve Johnson 2003-04-01 17:25:14 EST
I have also seen this. Updating to glibc 80.3 didn't fix it.

I've noticed that it seems to be timing dependant. I'm running on a dual 300 Mhz
SMP system. If I load one CPU down the problem seems to go away, at least it
doesn't happen as often. Updating from RH's RPM wine to the latest Wine
(3/18/2003) also didn't fix it.

Finally, I tried installing fonts into Wine by copying a bunch of Windows fonts
into C:/WINDOWS/Fonts, and the problem vanished. So here's what seems to work:

glibc 80.3
wine 3/18/2003
RH 8.0 SMP w/ all updates as of 4/1/2003, except for glibc as above
Required fonts in the Windows/Fonts folder

I suspect that the fonts trick was all that was required.
Comment 9 Need Real Name 2003-04-03 01:48:35 EST
On a dual Athlon, I get the

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 12161 requests (11917 known processed) with 0 events remaining.

reliably, after a few random seconds. Only booting non-SMP kernel solves the
problem.

glibc-2.3.2-4.80.3
wine-20020605-2 (also tried a few other versions)
Comment 10 Michael Evans 2003-04-05 05:32:45 EST
Got the same problem on a single processor I686 500MHz
RH 8.0 updated to 2004-04-04
Wine 20020605

glibc-2.3.2-4.80.4 update plus four VGA fonts in /Windows/Fonts 
solved/bypassed it.

Comment 11 Jakub Jelinek 2003-04-07 18:05:01 EDT
There is another thing.
wine (with exception of latest CVS wine) assumes it can override __errno_location
symbol and __h_errno_location symbol. But this is not possible in glibc 2.3.2
any longer, since glibc calls that function directly, bypassing .plt.
I've built glibc-2.3.2-4.80.6 in the same location which reverts the
changes which made __errno_location and __h_errno_location unoverridable.
Can you please check it out?
Comment 12 Jonathan Peatfield 2003-04-09 06:56:04 EDT
This (glibc-2.3.2-4.80.6) fixes all the problems I've seen with:

  cxoffice-1.2 (tested only with wordview/xlview but...)

  missing /lib/libnss*.so.1 files (we have some semi-statically linked
commercial apps which need them)

  random crashed with apps using pthreads (I guess this was the /lib/i686/ issue
mentioned above).

I know that QA can take a long time, but already this seems much better than
plain glibc-2.3.2-4.80, do you have any idea how long before we can expect to
see an official update RPM for RH8?

[ Do some fo these issues also affect the RH9 version of glibc, I suspect that
the ones related to kernel fun don't but some of the others probably do.  I've
not yet dared test RH9 (still waiting for feedback from those who paid to
beta-test it :-) ]
Comment 13 Jakub Jelinek 2003-04-09 15:21:28 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-136.html
Comment 14 John Wells 2003-04-23 10:34:41 EDT
I'm still getting:

XIO:  fatal IO error 0 (Success) on X server ":0.0"
      after 3765 requests (3752 known processed) with 0 events remaining.

on RHL 9 with the errata glibc installed.  Any word on what might be causing this? 

Specs:
Red Hat Linux 9
1.0 GHZ CPU
256 Megs ram
glibc-common-2.3.2-27.9
glibc-2.3.2-27.9
glibc-devel-2.3.2-27.9
glibc-kernheaders-2.4-8.10
Comment 15 R.K.Aa. 2003-04-23 15:12:05 EDT
RedHat 8 shuld asupposedly be supported untill Dec. 31st 2003. 
Has the support period been changed?  This bug is reported against RedHat 8. But
the errata glibc is still not published for RedHat8, only for RedHat 9!
Comment 16 Jakub Jelinek 2003-04-23 15:17:41 EDT
This is not true. See https://rhn.redhat.com/errata/RHSA-2003-089.html
Concerning wine on RHL9, unlike RHL8 you need to run very recent CVS wine
and configure it for NPTL.
Comment 17 Chris Ricker 2003-04-23 15:21:37 EDT
FWIW, I've tried both latest wine and crossover office 2.0 on RHL 9 + glibc
errata, and they both work....

Note You need to log in before you can comment on or make changes to this bug.