This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864377 - [RFE] Add testcase to check for all binaries required by the TUI
[RFE] Add testcase to check for all binaries required by the TUI
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 05:33 EDT by Fabian Deutsch
Modified: 2013-11-28 08:25 EST (History)
12 users (show)

See Also:
Fixed In Version: 2.7.0
Doc Type: Enhancement
Doc Text:
Feature: Add testcase to check for all binaries required by the TUI Reason: Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 08:25:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-10-09 05:33:10 EDT
Description of problem:
The TUI is using a number of external commands, because of packaging changes (e.g. the recent hostname change) it can happen that a binary is moved to another package which is not included in the Node package set. A testcase which checks for all required external binaries can be used to uncover these kind of problems.
Comment 1 Fabian Deutsch 2013-04-05 04:11:41 EDT
A better way might be to explicitly name the binaries in the spec file
Comment 2 Sandro Bonazzola 2013-11-19 03:10:47 EST
> Fixed In Version: 2.7.0

Is this fixed?
Comment 3 Fabian Deutsch 2013-11-28 08:25:18 EST
We adjusted the spec file dependencies - and didn't create a testcase.

Note You need to log in before you can comment on or make changes to this bug.