Bug 864391 - Section 2.1 errors in documentation
Section 2.1 errors in documentation
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 06:30 EDT by Radim Hatlapatka
Modified: 2012-11-08 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2012-10-09 06:30:43 EDT
One of the following packages must be installed s a prerequisite: apr-devel or apr-util-devel.

An updated installation of mod_auth_kerb. 

The list of prerequisities should be mentioned the same way, I suggest moving it to Procedure 2.2. Installing Required Packages

Another prerequisities are links and krb5-workstation package in order to have utilities such as kinit, kdestroy and klist
Comment 1 Misha H. Ali 2012-10-12 02:11:08 EDT
Can you confirm if I have understood this bug correctly, Radhim:

1. You would like it made more obvious that procedure 2.2 can be applied to all the packages listed as prerequisites in 2.1?

2. Add the following packages to 2.1 as prerequisite packages:

a. links
b. krb5-workstation

Is that correct? If not, please let me know where I have misunderstood.
Comment 2 Radim Hatlapatka 2012-10-17 02:38:40 EDT
Yes it is correct
Comment 3 Misha H. Ali 2012-10-18 23:44:43 EDT
I think this should be addressed now. Please verify here:

http://file.bne.redhat.com/~mhusnain/EWS2/Installation_Guide/tmp/en-US/html/ch-Installing_EWS_on_Red_Hat_Enterprise_Linux.html#proc-Installing_Required_Packages-Linux (List of Prerequisites)

and then in Procedure 2.2. Installing Required Packages
Comment 4 Radim Hatlapatka 2012-10-19 03:14:56 EDT
Please ask developers how it is with requirement of distcache and pcre.

From my testing I know, that distcache shouldn't be needed (I am using it without it as it is not in the system neither in repositories), but pcre is in default installed on RHEL and I don't know if it is really needed.

Why requirement of apr-devel or apr-util-devel is put separately and not as part of the bullet list?
Comment 5 Misha H. Ali 2012-10-20 22:52:18 EDT
Adding Wei Nan to verify if distcache and pcre are still required.

For your second point, radhim, they are separately because you can install one or the other and if they were lumped in with the separate packages, the command would have to be provided twice, once with one package and then with the second alternative.
Comment 6 Weinan Li 2012-10-23 02:33:16 EDT
Hi Misha, I'm working on this and will give you feedback soon.
Comment 7 Weinan Li 2012-10-23 10:59:17 EDT
These two packages are not needed and not necessary. Please remove requirements of 'pcre' and 'distcache', thanks :-)
Comment 8 Misha H. Ali 2012-10-23 19:28:36 EDT
Thanks for the clarification, Wei Nan! They are now removed from prerequisites, but a follow up question about the same:

In "Running the HTTP Server", we state that these two packages are required for the ZIP installation of EWS. You can see this here: http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/run_http_server-zip.html

Should they be removed as a prerequisite for the ZIP install to run httpd?
Comment 9 Misha H. Ali 2012-10-23 22:30:35 EDT
These packages are gone from the prerequisites:

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/ch-Installing_EWS_on_Red_Hat_Enterprise_Linux.html#sec-Prerequisites-Linux

This bug is ready for QA and if Wei Nan thinks these packages should be gone from the ZIP install to run HTTP content as well, this bug will be set back to ASSIGNED.
Comment 10 Weinan Li 2012-10-24 02:10:07 EDT
Hi Misha, these two packages are not required by ZIP distribution either.
Comment 11 Radim Hatlapatka 2012-10-24 10:27:41 EDT
In Procedure 2.2. Installing Required Packages you have wrong names of package krb5-workstation (you have there krb-5-workstation which is wrong) and elinks (you have there elink, which is also wrong)
Comment 12 Misha H. Ali 2012-10-24 20:04:52 EDT
* Changed the spelling of the krb5 package in Procedure 2.2.

* Changed the spelling of the elinks package in Procedure 2.2.

* Regarding comment#10, I have addressed this issue for another bug[1] and think these should be OK now. 

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=869552
Comment 14 Radim Hatlapatka 2012-10-25 07:01:59 EDT
The pcre and distcache are still in 2.4.6. Running the HTTP Server

I think that even if running it from rpm they should be removed.

The pcre and distcache are not mentioned in [1] and I think it is better to leave solving of this part of the issue in this bugzilla.


[1] - https://bugzilla.redhat.com/show_bug.cgi?id=869552
Comment 15 Misha H. Ali 2012-10-25 10:24:10 EDT
OK, removed mini procedure on how to install these packages and any mention of them in 2.4.6.
Comment 17 Libor Fuka 2012-10-26 03:07:32 EDT
distcache and pcre are removed - verified on dco stage
Comment 18 Misha H. Ali 2012-11-08 17:11:15 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.