This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 864424 - Section 2.2 of the Installation guide for EWS 2.0
Section 2.2 of the Installation guide for EWS 2.0
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-Installation-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0.1
Assigned To: Mandar Joshi
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 08:09 EDT by Radim Hatlapatka
Modified: 2015-08-31 22:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 07:58:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2012-10-09 08:09:21 EDT
In 2.2.4. Running Tomcat

JAVA_HOME may be set by other means. Either by setting it globally (for example by .bashrc) or rather setting it in tomcat{6,7}/bin/setenv.sh (It shouldn't be done directly in catalina.sh even though this is as well possible)

The best way is either providing JAVA_HOME from outside by having it set before running tomcat, or by putting it to tomcat{6,7}/bin/setenv.sh which is loaded from catalina.sh and overrides all other setting of JAVA_HOME for the tomcat

In 2.2.8.1.1. Running Tomcat as a Program

Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not changed from user, it is run under user who started it. But this should be consulted with developers if it is really the intended behaviour. Thus please consult it with them.

In 2.2.8.1.2. Running Tomcat as a Service

tanukiwrapper is no longer used => should be removed from here

In 2.2.11. Additional Resources

ZIP names should be updated to version 2.0.0
Comment 1 Misha H. Ali 2012-10-11 21:33:53 EDT
(In reply to comment #0)
> In 2.2.4. Running Tomcat
> 
> JAVA_HOME may be set by other means. Either by setting it globally (for
> example by .bashrc) or rather setting it in tomcat{6,7}/bin/setenv.sh (It
> shouldn't be done directly in catalina.sh even though this is as well
> possible)
> 
> The best way is either providing JAVA_HOME from outside by having it set
> before running tomcat, or by putting it to tomcat{6,7}/bin/setenv.sh which
> is loaded from catalina.sh and overrides all other setting of JAVA_HOME for
> the tomcat
> 

This should be fixed. Link to follow. Have also cleaned up this whole section into a procedure which is hopefully more ordered and some headers for starting and stopping tomcat.

> In 2.2.8.1.1. Running Tomcat as a Program
> 
> Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not
> changed from user, it is run under user who started it. But this should be
> consulted with developers if it is really the intended behaviour. Thus
> please consult it with them.
> 

OK, this is probably something Wei Nan can clarify. (Sorry again, Wei Nan :))

> In 2.2.8.1.2. Running Tomcat as a Service
> 
> tanukiwrapper is no longer used => should be removed from here
> 

Sorry , Radhim, I can't spot tanukiwrapper anywhere here. What I can see:

2.2.8.1.2. Running Tomcat as a Service

To run Tomcat as a service, create and use your own system daemon script with jsvc.

If you meant something else, could you clarify?

> In 2.2.11. Additional Resources
> 
> ZIP names should be updated to version 2.0.0

This is 2.2.10 now and the file names should be correct. I have left out CR1 from the names, please comment if this should be retained, I suspect the final zips will have GA or nothing instead of CR1?
Comment 2 Misha H. Ali 2012-10-21 19:00:28 EDT
Setting back to assigned pending clarification from Wei Nan regarding the last point:

> In 2.2.8.1.1. Running Tomcat as a Program
> 
> Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not
> changed from user, it is run under user who started it. But this should be
> consulted with developers if it is really the intended behaviour. Thus
> please consult it with them.
> 

OK, this is probably something Wei Nan can clarify. (Sorry again, Wei Nan :))
Comment 3 Misha H. Ali 2012-10-25 00:24:40 EDT
Wei Nan, requesting information for the above (last bug) whenever you next get a few moments. :)
Comment 5 Misha H. Ali 2013-04-11 19:05:54 EDT
assuming the information request is filled, nominating this for 2.0.1.
Comment 6 Mandar Joshi 2013-05-28 07:41:46 EDT

> In 2.2.8.1.1. Running Tomcat as a Program
> 
> Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not
> changed from user, it is run under user who started it. But this should be
> consulted with developers if it is really the intended behaviour. Thus
> please consult it with them.
> (In reply to Radim Hatlapatka from comment #0)
> In 2.2.4. Running Tomcat
> 
> JAVA_HOME may be set by other means. Either by setting it globally (for
> example by .bashrc) or rather setting it in tomcat{6,7}/bin/setenv.sh (It
> shouldn't be done directly in catalina.sh even though this is as well
> possible)
> 
> The best way is either providing JAVA_HOME from outside by having it set
> before running tomcat, or by putting it to tomcat{6,7}/bin/setenv.sh which
> is loaded from catalina.sh and overrides all other setting of JAVA_HOME for
> the tomcat

This is implemented in Procedure 2.5. Setting JAVA_HOME


> 
> In 2.2.8.1.1. Running Tomcat as a Program
> 
> Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not
> changed from user, it is run under user who started it. But this should be
> consulted with developers if it is really the intended behaviour. Thus
> please consult it with them.

 Hi David, can you please provide information on this?

> 
> In 2.2.8.1.2. Running Tomcat as a Service
> 
> tanukiwrapper is no longer used => should be removed from here

I can't spot tanukiwrapper anywhere here
> 
> In 2.2.11. Additional Resources
> 
> ZIP names should be updated to version 2.0.0

ZIP  names have been updated.
Comment 7 Misha H. Ali 2013-05-31 01:20:43 EDT
This bug will be set to ON_QA when the changes above appear on the docs stage and can be verified by QA.
Comment 8 Mandar Joshi 2013-06-04 05:45:04 EDT
> In 2.2.4. Running Tomcat
> 
> JAVA_HOME may be set by other means. Either by setting it globally (for
> example by .bashrc) or rather setting it in tomcat{6,7}/bin/setenv.sh (It
> shouldn't be done directly in catalina.sh even though this is as well
> possible)
> 
> The best way is either providing JAVA_HOME from outside by having it set
> before running tomcat, or by putting it to tomcat{6,7}/bin/setenv.sh which
> is loaded from catalina.sh and overrides all other setting of JAVA_HOME for
> the tomcat.

	Topic modified: Set JAVA_HOME (ZIP and RPM) [17123]

> In 2.2.8.1.1. Running Tomcat as a Program
> 
> Tomcat on RHEL doesn't run necessarly under Tomcat user (the user is not
> changed from user, it is run under user who started it. But this should be
> consulted with developers if it is really the intended behaviour. Thus
> please consult it with them.

 Hi David, can you please provide information on this? - Yet to confirm (Needinfo is open)
	
	Topic: Running Tomcat as a Program [17745]

> In 2.2.8.1.2. Running Tomcat as a Service
> 
> tanukiwrapper is no longer used => should be removed from here

	Topic Modified: Running Tomcat as a Service (ZIP) [17744]

> In 2.2.11. Additional Resources
> 
> ZIP names should be updated to version 2.0.0

	Topic Modified: Additional Resources [10946]
Comment 10 Misha H. Ali 2013-06-05 05:22:52 EDT
1. The new text for setting JAVA_HOME is available in Procedure 2.6. Setting JAVA_HOME in 2.5.2

2. Running Tomcat as a Program user info is not answered, so no change. Moved to separate bug for another release. See bug 970935 for details

3. Running Tomcat as a service - no mention of tanukiwrapper found. No change.

4. Already set to 2.0.0 for 2.0.0 docs. No change. To review, please view "2.5. 10. Additional Resources"

This bug will be set to ON_QA when the changes are available on the staging server.
Comment 14 Libor Fuka 2013-06-07 05:58:39 EDT
the zip names are with 2.0.1 not 2.0.0
please update this in all installation guide
Comment 16 Libor Fuka 2013-06-10 02:55:17 EDT
There are still many places with 2.0.0 in installation guide.
Comment 17 Mandar Joshi 2013-06-10 05:01:26 EDT
All the instances of 2.0.0 have been replaced by 2.0.1 in the EWS Installation Guide.

Following is the list of topics updated:

Topics updated
Chapter: Installing Enterprise Web Server on Windows
        Topic:Downloading and Extracting Installation File
        Updated file name "jboss-ews-application-servers-2.0.1" and "jboss-ews-httpd-2.0.1"

Chapter: Installing Enterprise Web Server on Solaris
        Topic: Downloading Installation Files
        Updated file name "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip" and "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"


Chapter: Introduction
        Topic: Product Documentation Locations
        Updated filename "jboss-ews-docs-2.0.1.zip"

Chapter: Installing Enterprise Web Server on Red Hat Enterprise Linux
        Topic: ZIP Installation Files
        Updated filenames "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip", "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"

        Topic: Installing Enterprise Web Server from a ZIP File
        Updated Filename "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip", "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip", "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip" "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"

        Topic: Configuring the Environment
        Updated filename "jboss-ews-docs-2.0.1.zip"
Comment 18 Mandar Joshi 2013-06-11 02:56:03 EDT
(In reply to Mandar Joshi from comment #17)
For verification, please see the link inline.

> All the instances of 2.0.0 have been replaced by 2.0.1 in the EWS
> Installation Guide.
> 
> Following is the list of topics updated:
> 
> Topics updated
> Chapter: Installing Enterprise Web Server on Windows
>         Topic:Downloading and Extracting Installation File
>         Updated file name "jboss-ews-application-servers-2.0.1" and
> "jboss-ews-httpd-2.0.1"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Downloading_and_Extracting_Installation_File-Win.html
> 
> Chapter: Installing Enterprise Web Server on Solaris
>         Topic: Downloading Installation Files
>         Updated file name
> "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip" and
> "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Downloading_Installation_Files-Sol.html
> 
> 
> Chapter: Introduction
>         Topic: Product Documentation Locations
>         Updated filename "jboss-ews-docs-2.0.1.zip"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/Install_Guide-Documentation_Links.html
> 
> Chapter: Installing Enterprise Web Server on Red Hat Enterprise Linux
>         Topic: ZIP Installation Files
>         Updated filenames
> "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip",
> "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/ch-Installing_EWS_on_Red_Hat_Enterprise_Linux.html#sec-Prereq_RHEL_Install_ZIP
> 
>         Topic: Installing Enterprise Web Server from a ZIP File
>         Updated Filename
> "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip",
> "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip",
> "jboss-ews-application-servers-2.0.1-<platform>-<architecture>.zip"
> "jboss-ews-httpd-2.0.1-<platform>-<architecture>.zip"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Installing_EWS_from_a_ZIP_File-Linux.html
> 
>         Topic: Configuring the Environment
>         Updated filename "jboss-ews-docs-2.0.1.zip"

http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Enterprise_Web_Server/2/html/Installation_Guide/sec-Configuring_the_Environment-Linux-ZIP.html
Comment 19 Libor Fuka 2013-06-11 03:00:28 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.