Bug 864527 - aeolus-conductor should install converge-ui into a clean directory
aeolus-conductor should install converge-ui into a clean directory
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: beta6
: ---
Assigned To: John Eckersberg
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 10:08 EDT by John Eckersberg
Modified: 2012-12-04 10:08 EST (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.21-1.el6cf.src.rpm
Doc Type: Bug Fix
Doc Text:
The Cloud Engine source generated RPMs by copying files from converge-ui-devel to overwrite certain files in an existing directory. However, some converge-ui files already existed in Cloud Engine and were not overwritten, which produced an error upon building the RPMS. This bug fix removes the old converge-ui contents before replacing with converge-ui-devel and generating new RPMs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:08:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2012-10-09 10:08:03 EDT
Description of problem:
aeolus-conductor has a buildrequires on converge-ui-devel.  At build time, the conductor spec copies the converge-ui files, as shipped in the converge-ui-devel rpm, into its tree.  However, depending on how the aeolus-conductor tarball was originally generated, the aeolus-conductor tarball may also contain converge-ui bits.  The interaction of copying the converge-ui-devel data overtop of the aeolus-conductor tarball data is murky at best, and should be avoided.  Before copying, the specfile should remove any existing converge-ui bits to ensure a predictable build.

Version-Release number of selected component (if applicable):
aeolus-conductor-0.13.17-1.el6cf
Comment 2 John Eckersberg 2012-10-10 10:37:12 EDT
https://github.com/aeolusproject/conductor/pull/112
Comment 3 John Eckersberg 2012-10-10 10:38:45 EDT
Correction, https://github.com/aeolusproject/conductor/pull/113
Comment 4 Steve Linabery 2012-10-10 17:26:12 EDT
0243d2f on master
2abc6ca on 1.1
Comment 7 Giulio Fidente 2012-10-26 05:49:51 EDT
this is included in aeolus-conductor-0.13.21-1.el6cf.src.rpm , closing as VERIFIED
Comment 9 errata-xmlrpc 2012-12-04 10:08:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.