Bug 86460 - can't create lvm module
can't create lvm module
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: raidtools (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-03-22 17:04 EST by Greg Little
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: 3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-11-12 13:51:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg Little 2003-03-22 17:04:15 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
There is no way to enable lvm in the Advanced Server 2.1

I tried enabling it as a module in the config, but when I insmod the module, I 
get unresolved symbols.

Also, compiling the source from sistina, patching the kernel and recompiling, 
even without the GPL-checking, does not work.

There are no rpm's for AS2.1, however there are rpms for 8 and 7.3. I actually 
need the ability to resize partitions and create volumes, since I am using a 
Dell/AS2.1 cluster. 

Steps to Reproduce:
1. install kernel-source rpm. make menuconfig, modularize LVM and LVM_PROC_FS.
2. make dep modules bzImage modules install
3. init 6
4. insmod lvm
Actual results:
unresolved symbols

Expected results:


Additional info:
Comment 1 Arjan van de Ven 2003-03-22 17:08:37 EST
lvm is not supported in AS2.1. The code is disabled in the config because the
version of LVM in 2.4.9 corrupts data in some cases and we only fixed that after
the release (eg for 7.3). 
Comment 2 Greg Little 2003-03-22 17:39:13 EST
Will there ever be a newer kernel for AS2.1? It looks like the updates are to 
the 2.4.9 kernel rather than a newer kernel. Oracle/Dell certified AS2.1, yet 
in use I need to make a large number of partitions (39 and counting) but can't 
w/o lvm. I also can't resize existing partitions. Am I completely missing 
something here? 

Also, the lvm in the redhat rpms is 1.0.3, but sistina considers 1.0.6 to be 
the stable release. 

Is anyone working on getting lvm into AS2.1?
Comment 3 Jason Dixon 2003-07-22 21:19:16 EDT
There hasn't been any updates to this bug over the last 4 months.  What is the
status of LVM for upcoming RHAS releases?
Comment 4 Greg Little 2003-11-12 13:51:15 EST
The fix is in. I have installed and tested RHAS 3.0 and the lvm 
definitely works. 


Note You need to log in before you can comment on or make changes to this bug.