Bug 864609 - All settings disappeared after upgrade
All settings disappeared after upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 14:12 EDT by Zdenek Kabelac
Modified: 2012-10-22 09:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 09:00:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2012-10-09 14:12:08 EDT
Description of problem:

It looks like all my NetworkManager settings are lost somewhere or at least not being recognized by this new NetworkManager running on my rawhide machine
since it seems all my VPN, modem, eth0 settings are still laying in their dirs in /etc/NetworkManager and /etc/sysconfig.

It seems  'nmcli' to still list all the connections properly - but nm-applet
doesn't provide them - so it hard to tell to which package file this bug.

Version-Release number of selected component (if applicable):

NetworkManager-0.9.7.0-4.git20121004.fc19.x86_64
NetworkManager-debuginfo-0.9.7.0-4.git20121004.fc19.x86_64
NetworkManager-vpnc-0.9.3.997-3.fc18.x86_64
NetworkManager-glib-0.9.7.0-4.git20121004.fc19.x86_64

network-manager-applet-0.9.7.0-3.git20121004.fc19.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jirka Klimes 2012-10-16 04:11:11 EDT
If nmcli or other D-Bus clients sees the data, the nm-applet is probably misbehaving.

Do you see any errors regarding NM in /var/log/messages?
nm-applet logs are directed to ~/.xsession-errors. Or you can run it in a terminal and see output there.
Comment 2 Zdenek Kabelac 2012-10-16 04:40:47 EDT
I think, the part of the problem could have been, that upgrade was made on live machine - thus  nm-applet could have been possibly confused if the NM has changed?

It seems that after next upgrade and machine reboot problem has gone away.

(And came a new one - when normal Wifi connection is being reported with no-signal icon (all little bars are white instead of blue).

Using this version.

NetworkManager-0.9.7.0-4.git20121004.fc19.x86_64
Comment 3 Dan Winship 2012-10-19 08:12:39 EDT
(In reply to comment #2)
> I think, the part of the problem could have been, that upgrade was made on
> live machine - thus  nm-applet could have been possibly confused if the NM
> has changed?
> 
> It seems that after next upgrade and machine reboot problem has gone away.

ok, we'll assume it was something having to do with mismatched daemon/applet or something.

> (And came a new one

if you're still seeing that, please file a new bug
Comment 4 Zdenek Kabelac 2012-10-22 08:59:53 EDT
Ok - finally played a bit a get to the trick how this happens.

So the key part here is - the I've to start  Xsession on wired docked T61.

Then I remove T61 from dock and I try to use  Wifi network.

When the first connection happens - icon with signal quality has no 'blue bar' even thought connection is OK.

Then if I disconnect and reconnect - icon get all bars blue and looks ok.

So the important part in this seems to be starting  Xsession in dock station.
If I start my Xsession undocked - it's ok all the time.

Reliably happens with:

NetworkManager-0.9.7.0-6.git20121004.fc19.x86_64
network-manager-applet-0.9.7.0-3.git20121016.fc19.x86_64
Comment 5 Zdenek Kabelac 2012-10-22 09:04:36 EDT
So my problem is probably this bug: 832153

Note You need to log in before you can comment on or make changes to this bug.