Bug 864646 - The configd doesn't correctly parse DAEMON_LIST with space separated list of daemons
The configd doesn't correctly parse DAEMON_LIST with space separated list of ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-client (Show other bugs)
2.2
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 16:43 EDT by Robert Rati
Modified: 2016-05-26 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 16:06:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-10-09 16:43:50 EDT
Description of problem:
The DAEMON_LIST in the base-db that is defined in the HACentralManager feature is defiend with spaces, like this:
    DAEMON_LIST: ">= HAD REPLICATION"
This causes the configd to look for a daemon named 'had replication' instead of seeing the two as separate daemons.

Version-Release number of selected component (if applicable):
condor-wallaby-client-4.1.3-1

How reproducible:
100%

Steps to Reproduce:
1. wallaby add-features-to-group +++DEFAULT Master NodeAccess ExecuteNode
2. wallaby add-params-to-group +++DEFAULT CONDOR_HOST=<cm1>,<cm2>,<cm3> ALLOW_READ=* ALLOW_WRITE=*
3. wallaby add-group HACM
4. wallaby add-nodes-to-group HACM <cm1> <cm2> <cm2>
5. wallaby add-features-to-group HACM HACentralManager
6. wallaby add-params-to-group HACM HAD_LIST=<cm1>:\$\(HAD_PORT\),<cm2>:\$\(HAD_PORT\),<cm3>:\$\(HAD_PORT\) REPLICATION_LIST=<cm1>:\$\(REPLICATION_PORT\),<cm2>:\$\(REPLICATION_PORT\),<cm3>:\$\(REPLICATION_PORT\)
7. wallaby activate
8. Wait until negotiator comes up on <cm1>
9. wallaby remove-nodes-from-group HACM <cm1>
10. wallaby add-params-to-group HACM HAD_LIST=<cm2>:\$\(HAD_PORT\),<cm3>:\$\(HAD_PORT\) REPLICATION_LIST=<cm2>:\$\(REPLICATION_PORT\),<cm3>:\$\(REPLICATION_PORT\)
11. wallaby add-params-to-group +++DEFAULT CONDOR_HOST=<cm2>,<cm3> ALLOW_READ=* ALLOW_WRITE=*
12. wallaby activate
13. Look in the ConfigLog to notice:
10/09 14:54:02 DEBUG: Not sending "condor_restart" to subsystem "had" since it is not currently running
10/09 14:54:02 DEBUG: Not sending "condor_restart" to subsystem "replication" since it is not currently running
  
Actual results:
The config will not attempt to send a restart event to the had or replication daemon because it thinks they are not running.

Expected results:
The configd will send a restart event to the had and replication daemons

Additional info:
Comment 1 Anne-Louise Tangring 2016-05-26 16:06:28 EDT
MRG-Grid is in maintenance and only customer escalations will be considered. This issue can be reopened if a customer escalation associated with it occurs.

Note You need to log in before you can comment on or make changes to this bug.