Bug 864701 - bridge + private network breaks guest DNS
bridge + private network breaks guest DNS
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 19:11 EDT by Matthew Woehlke
Modified: 2016-03-23 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 20:54:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Woehlke 2012-10-09 19:11:15 EDT
Description of problem:
I have a guest configured with one NIC connected to the host NIC in bridge mode. However, for various reasons (originally because it was the only way for the guest and host to talk to each other, now also because it is a convenient way to isolate host<->guest network services) I have a second guest NIC connected to a libvirt private network.

This configuration breaks DNS on the guest because it only sees the dnsmasq server from the private network (which apparently does not provide forwarding of the host's DNS, though this is probably correct behavior given it is a private network). In order to get useable DNS resolution, I must restart the guest NIC bridged to the host NIC (which resets the guest's /etc/resolv to the DNS servers as provided by the external LAN's DHCP server).

Version-Release number of selected component (if applicable):
libvirt-0.9.11.5-3.fc17.x86_64

How reproducible:
Seemingly always

Steps to Reproduce:
1. Configure guest with two NIC's; one using a libvirt private network, one using the host NIC in bridge mode.
2. Start guest
3. Attempt to resolve addresses from the host LAN
  
Actual results:
Guest cannot resolve names of machines on external LAN.

Expected results:
Guest can resolve names of machines on external LAN.

Additional info:
As I do not know how to get the guest to append DNS configurations, would it be possible/reasonable to add similar functionality to libvirt? Failing that, it would be nice if libvirt had an option to disable DNS services on a libvirt network (i.e. pass '--port 0' to dnsmasq).
Comment 1 Cole Robinson 2016-03-23 20:54:23 EDT
Sorry this never received a response, but I think this was fixed in libvirt over the years. Some info here: https://www.redhat.com/archives/libvirt-users/2014-April/msg00028.html

Note You need to log in before you can comment on or make changes to this bug.