Bug 864728 - The floating top bar obscures the title of the target when you click on a #hash url
The floating top bar obscures the title of the target when you click on a #ha...
Status: CLOSED DUPLICATE of bug 847797
Product: Publican
Classification: Community
Component: publican-redhat (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Jeff Fearn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 21:43 EDT by Simon Baird
Modified: 2012-10-14 20:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 20:16:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Baird 2012-10-09 21:43:44 EDT
For example, click here:

https://pride.engineering.redhat.com/docs/en-US/Infrastructure_Engineering_and_Development/2012/html-single/Engineering_Gerrit_User_Guide/index.html

The click on one of the links in the table of contents, eg:

https://pride.engineering.redhat.com/docs/en-US/Infrastructure_Engineering_and_Development/2012/html-single/Engineering_Gerrit_User_Guide/index.html#gerrit-registration

Notice that the "Gerrit Registration" title is not visible after you click. This is confusing. The user wonders if the link might be broken of if they clicked the wrong link. It's not good UX for the user.

Note that after a few seconds the floating top bar disappears, then the heading becomes visible.

Not sure about the best way to fix it. Perhaps there could be some javascript to scroll down a bit extra after the link is clicked so the target is visible below the toolbar. Or perhaps the floating bar could auto-hide when the user follows a link to a section within the page.
Comment 1 Simon Baird 2012-10-09 21:48:42 EDT
More accessible example:

Click here:

https://engineering.redhat.com/docs/en-US/Infrastructure_Engineering_and_Development/1/html-single/Configuring_Kerberos_on_JBoss_EAP/index.html

Click something in table of contents, eg "Security Domains"

Notice title is obscured.
Comment 2 Jeff Fearn 2012-10-14 20:16:39 EDT

*** This bug has been marked as a duplicate of bug 847797 ***

Note You need to log in before you can comment on or make changes to this bug.