Bug 864731 - please split out -docs subpackage
please split out -docs subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 21:50 EDT by Matthew Miller
Modified: 2012-10-11 02:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: libxml2-2.9.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 02:41:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-10-09 21:50:15 EDT
Description of problem:

We're trying to get the Fedora cloud image as small as possible. Moving all docs out of the minimal image is a harder task, but there are some relatively 

libxml2 takes up 5.2M, of which 3.8M is docs, and which look mostly to be development documentation.

Could these either be moved to a -docs subpackage, or to the -devel subpackage?



Version-Release number of selected component (if applicable):

I'm looking at libxml2-2.7.8 in F17 right now, but I'm most concerned with moving forward.
Comment 1 Daniel Veillard 2012-10-11 02:41:45 EDT
Actually the docs were duplicated in the the main package
and in the devel one, I just cleaned them up (a bit convoluted
it was installed as part of "make install" not %doc !)

thinkpad:~/fcpkgs/libxml2/master -> rpm -qilp /home/veillard/rpms/RPMS/x86_64/libxml2-2.9.0-2.fc17.x86_64.rpm
Name        : libxml2
Version     : 2.9.0
...
Size        : 1644597
...
/usr/bin/xmlcatalog
/usr/bin/xmllint
/usr/lib64/libxml2.so.2
/usr/lib64/libxml2.so.2.9.0
/usr/share/doc/libxml2-2.9.0
/usr/share/doc/libxml2-2.9.0/AUTHORS
/usr/share/doc/libxml2-2.9.0/Copyright
/usr/share/doc/libxml2-2.9.0/NEWS
/usr/share/doc/libxml2-2.9.0/README
/usr/share/doc/libxml2-2.9.0/TODO
/usr/share/man/man1/xmlcatalog.1.gz
/usr/share/man/man1/xmllint.1.gz
/usr/share/man/man3/libxml.3.gz
thinkpad:~/fcpkgs/libxml2/master -> 

  Back to the strict minimum, I alsoc removed the old ChangeLog
which didn't made sense anymore since we switched to git.

  I build libxml2-2.9.0-2.fc19 for rawhide, i will probably do the same for
f18 soon

Daniel

Note You need to log in before you can comment on or make changes to this bug.