Bug 864737 - RuntimeError: plugins already initialised
RuntimeError: plugins already initialised
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:f1ca84a775a4c31be06869b5596...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-09 22:13 EDT by Reartes Guillermo
Modified: 2013-01-09 21:24 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-18.21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 22:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (274.99 KB, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: storage.log (117.25 KB, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: environ (764 bytes, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (2.68 KB, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: syslog (73.39 KB, text/plain)
2012-10-09 22:13 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-09 22:14 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.60 KB, text/plain)
2012-10-09 22:14 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-09 22:14 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-09 22:14 EDT, Reartes Guillermo
no flags Details
File: program.log (41.70 KB, text/plain)
2012-10-09 22:14 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-09 22:13:26 EDT
Description of problem:
boot, acepted fate, switched to closest mirror too quicly (this similar tho another bug)

Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 617, in doPluginSetup
:    raise RuntimeError(_("plugins already initialised"))
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 373, in _getConfig
:    startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    conf = property(fget=lambda self: self._getConfig(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 675, in _getRepos
:    self.conf # touch the config class first
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1005, in <lambda>
:    repos = property(fget=lambda self: self._getRepos(),
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 352, in repos
:    return self._yum.repos.repos.keys()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 363, in baseRepo
:    if repo_name in self.repos and \
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/software.py", line 137, in status
:    if threadMgr.get("AnaPayloadMDThread") or self.payload.baseRepo is None:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 198, in _updateCompleteness
:    spoke.selector.set_property("status", spoke.status)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 255, in _update_spokes
:    self._updateCompleteness(spoke)
:RuntimeError: plugins already initialised
Comment 1 Reartes Guillermo 2012-10-09 22:13:36 EDT
Created attachment 624418 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-09 22:13:38 EDT
Created attachment 624419 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-09 22:13:40 EDT
Created attachment 624420 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-09 22:13:42 EDT
Created attachment 624421 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-09 22:13:47 EDT
Created attachment 624422 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-09 22:13:49 EDT
Created attachment 624423 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-09 22:13:51 EDT
Created attachment 624424 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-09 22:13:54 EDT
Created attachment 624425 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-09 22:13:57 EDT
Created attachment 624426 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-09 22:14:00 EDT
Created attachment 624427 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-09 22:14:03 EDT
Created attachment 624428 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-09 22:14:05 EDT
Created attachment 624429 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-09 22:14:07 EDT
Created attachment 624430 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-09 22:14:10 EDT
Created attachment 624431 [details]
File: program.log
Comment 15 Chris Lumens 2012-10-10 14:38:10 EDT
Could you expand upon your steps for reproducing this?  It sounds highly timing-dependent.
Comment 16 Reartes Guillermo 2012-10-17 15:16:59 EDT
Yes, it looks that timing is key here. 
The following must be performed as fast as possible.

1- select default language (leave as engish) in the WELCOME screen
2- accept your fate
3- enter INSTALATION SOURCE and select ON THE NETWORK and NEAREST MIRROR
and return to the main hub. 

Notes:
* Changing the nameserver before trying does not prevent the issue.
* Waiting in the WELCOME screen does not prevent the issue.

* By just waiting some seconds after entering INSTALLATION SOURCE, the
issue is avoided.

* Waiting for GNOME dependencies to be resolved before entering 
INSTALLATION SOURCE also prevents the issue from happening.

So, it appears that swiching the INSTALLATION SOURCE while GNOME 
dependencies are being resolved from DVD to NEAREST MIRROR can cause
this issue. 

Nevertheless, anaconda should not crash. 
Maybe it is not 100% safe to switch INSTALLATION SOURCE while dependencies
are being resolved.

And lastly, my 'NEAREST MIRROR' will not be the same for other people? 
After all, it is a mirror. What if there is some issue there?
Comment 17 Reartes Guillermo 2012-10-17 15:52:49 EDT
Take a look at 867591, it is the inverse problem (switching from CLOSEST MIRROR to DVD while resolving dependencies).
Comment 18 Chris Lumens 2012-10-22 10:51:30 EDT
I believe Jesse's fix for bug 867591 will fix this issue too, though, because you will be prevented from doing step #3 above - you will not be able to enter the source spoke while dep checking progresses.
Comment 19 Adam Williamson 2012-11-22 22:36:03 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.