Bug 864797 - Lost disable_auto_scaling mark in the README file of app markers
Lost disable_auto_scaling mark in the README file of app markers
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
: 848275 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 03:17 EDT by Rony Gong
Modified: 2015-05-14 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 19:55:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-10-10 03:17:38 EDT
Description of problem:
Since now we could disable auto scaling by add disable_auto_scaling in markers
touch $app_folder/.openshift/markers/disable_auto_scaling, so there need a marker explanation in  $app_folder/.openshift/markers/README


Version-Release number of selected component (if applicable):
devenv_2304

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
add the marker "disable_auto_scaling" explanation in to file $app_folder/.openshift/markers/README

Additional info:
Comment 1 Paul Morie 2013-01-07 11:32:34 EST
Added documentation; available in next devenv AMI.
Comment 2 Rony Gong 2013-01-07 21:24:25 EST
Checked on devenv_2641
All cartridges fixed except the cartridge jbossews-2.0's README file doesn't include the line:
disable_auto_scaling - Will prevent scalable applications from scaling up
                       or down according to application load.

So reopened,
Comment 3 Paul Morie 2013-01-10 16:16:56 EST
I double-checked and the README file contains an explanation for this marker in jbossews-2.0.

https://github.com/openshift/origin-server/tree/master/cartridges/openshift-origin-cartridge-jbossews-2.0/template/.openshift/markers

P
Comment 4 Rony Gong 2013-01-11 02:34:00 EST
Retest on devenv_2662
For scalable jbossews-2.0 still couldn't find the "disable_auto_scaling" flag.
Also checked the instance file:
[root@ip-10-73-29-105 ~]# rpm -qa|grep cartridge|xargs rpm -ql|grep "jbossews-2.0"|grep README
/usr/libexec/openshift/cartridges/jbossews-2.0/README
/usr/libexec/openshift/cartridges/jbossews-2.0/template/.openshift/cron/README.cron
/usr/libexec/openshift/cartridges/jbossews-2.0/template/.openshift/cron/weekly/README
/usr/libexec/openshift/cartridges/jbossews-2.0/template/.openshift/markers/README
/usr/libexec/openshift/cartridges/jbossews-2.0/template/README
[root@ip-10-73-29-105 ~]# cat /usr/libexec/openshift/cartridges/jbossews-2.0/template/.openshift/markers/README
Markers
===========

Adding marker files to this directory will have the following effects:

enable_jpda - Will enable the JPDA socket based transport on the java virtual
              machine running the JBoss AS 7 application server. This enables
              you to remotely debug code running inside the JBoss AS 7
              application server.

skip_maven_build - Maven build step will be skipped

force_clean_build - Will start the build process by removing all non 
essential Maven dependencies.  Any current dependencies specified in 
your pom.xml file will then be re-downloaded.

hot_deploy - Will prevent a JBoss container restart during build/deployment.
             Newly build archives will be re-deployed automatically by the
             JBoss HDScanner component.

java7 - Will run JBoss EAP with Java7 if present. If no marker is present then the 
			baseline Java version will be used (currently Java6)
Comment 5 Paul Morie 2013-01-11 12:53:34 EST
It appears that this was blocked by an issue with the jbossews-2.0 cartridge which new builds of were disabled for.  There's a pull request to re-enable builds - this change will be present once that pull request has merged.  I will comment with the devenv AMI id.
Comment 6 Paul Morie 2013-01-11 16:17:42 EST
The pull request has been merged - change should be present in devenv AMI 2667.
Comment 7 Meng Bo 2013-01-14 00:51:50 EST
Checked on devenv_2669, issue has been fixed. The contents about disable_auto_scaling appear in both template and app repo dir.

# cat /usr/libexec/openshift/cartridges/jbossews-2.0/template/.openshift/markers/README
Markers
===========

Adding marker files to this directory will have the following effects:

enable_jpda - Will enable the JPDA socket based transport on the java virtual
              machine running the JBoss AS 7 application server. This enables
              you to remotely debug code running inside the JBoss AS 7
              application server.

skip_maven_build - Maven build step will be skipped

force_clean_build - Will start the build process by removing all non 
essential Maven dependencies.  Any current dependencies specified in 
your pom.xml file will then be re-downloaded.

hot_deploy - Will prevent a JBoss container restart during build/deployment.
             Newly build archives will be re-deployed automatically by the
             JBoss HDScanner component.

java7 - Will run JBoss EAP with Java7 if present. If no marker is present then the 
			baseline Java version will be used (currently Java6)

disable_auto_scaling - Will prevent scalable applications from scaling up 
                       or down according to application load.
Comment 8 Paul Morie 2013-01-14 13:18:31 EST
*** Bug 848275 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.