Bug 864901 - Can't install fop rpm on centos 5.7 with EPEL Testing repo due to deps on batik 1.7 not available on EPEL Testing
Can't install fop rpm on centos 5.7 with EPEL Testing repo due to deps on bat...
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: fop (Show other bugs)
el5
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 07:13 EDT by FALQUE Benjamin
Modified: 2013-03-03 13:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-03 13:23:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FALQUE Benjamin 2012-10-10 07:13:01 EDT
Description of problem:


I can't install rpm fop on a centos 5.7 server when I enable EPEL Testing repositories cause I have a dependance with the rpm batik >= 1.7 but this rpm is not available in EPEL testing repositories.


Version-Release number of selected component (if applicable):

fop.noarch 0:0.95-1.el5
batik >= 1.7

How reproducible:

launch the command : yum --enablerepo=epel-testing install fop


Steps to Reproduce:

just try to install fop with EPEL Testint repo enabled
  

Actual results:

fop-0.95-1.el5.noarch from epel-testing has depsolving problems
  --> Missing Dependency: batik >= 1.7 is needed by package fop-0.95-1.el5.noarch (epel-testing)
Error: Missing Dependency: batik >= 1.7 is needed by package fop-0.95-1.el5.noarch (epel-testing)


Expected results:

fop rpm installed and deps on batik 1.7 resolved


Additional info:

Here the installation log : 

# yum --enablerepo=epel-testing install fop


Resolving Dependencies
--> Running transaction check
---> Package fop.noarch 0:0.95-1.el5 set to be updated
--> Processing Dependency: avalon-framework >= 4.1.4 for package: fop
--> Processing Dependency: xalan-j2 >= 2.7.0 for package: fop
--> Processing Dependency: batik >= 1.7 for package: fop
--> Processing Dependency: xml-commons-apis >= 1.3.04 for package: fop
--> Processing Dependency: jakarta-commons-httpclient for package: fop
--> Processing Dependency: java-1.6.0-openjdk for package: fop
--> Running transaction check
---> Package avalon-framework.x86_64 0:4.1.4-2jpp.13 set to be updated
---> Package fop.noarch 0:0.95-1.el5 set to be updated
--> Processing Dependency: batik >= 1.7 for package: fop
---> Package jakarta-commons-httpclient.x86_64 1:3.0-7jpp.1 set to be updated
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-1.28.1.10.9.el5_8 set to be updated
--> Processing Dependency: tzdata-java for package: java-1.6.0-openjdk
--> Processing Dependency: libgif.so.4()(64bit) for package: java-1.6.0-openjdk
---> Package jdk.i586 2000:1.6.0_18-fcs set to be updated
---> Package xalan-j2.x86_64 0:2.7.0-6jpp.1 set to be updated
--> Running transaction check
---> Package fop.noarch 0:0.95-1.el5 set to be updated
--> Processing Dependency: batik >= 1.7 for package: fop
---> Package giflib.x86_64 0:4.1.3-7.3.3.el5 set to be updated
---> Package tzdata-java.x86_64 0:2012f-1.el5 set to be updated
--> Finished Dependency Resolution
fop-0.95-1.el5.noarch from epel-testing has depsolving problems
  --> Missing Dependency: batik >= 1.7 is needed by package fop-0.95-1.el5.noarch (epel-testing)
Error: Missing Dependency: batik >= 1.7 is needed by package fop-0.95-1.el5.noarch (epel-testing)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 1 Peter Lemenkov 2013-03-03 13:23:27 EST
Fop was removed from EPEL.

Note You need to log in before you can comment on or make changes to this bug.