Bug 864904 - Auto-wrap long anchors in message preview
Auto-wrap long anchors in message preview
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
: 876883 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 07:19 EDT by Matěj Cepl
Modified: 2014-06-17 21:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: evolution-3.8.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:32:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast of the issue (329.36 KB, image/png)
2012-10-10 07:19 EDT, Matěj Cepl
no flags Details
test message (17.16 KB, text/plain)
2012-10-10 07:21 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2012-10-10 07:19:34 EDT
Created attachment 624790 [details]
screencast of the issue

Description of problem:
Not much to say ... see attached screenshot of the rendering of (also) attached email.

Version-Release number of selected component (if applicable):
evolution-3.6.0-1.el7.x86_64

Actual results:
Text is not wrapped properly and is partially hidden outside of the app window.

Expected results:
In case the text doesn't fit to the window, it should be always wrapped.

Additional info:
Comment 1 Matěj Cepl 2012-10-10 07:21:04 EDT
Created attachment 624791 [details]
test message
Comment 4 Milan Crha 2013-10-09 10:23:50 EDT
It's as wide as the shortest line in the text, which is the URL at the end of the document. When I break it with spaces it gets wrapped and the text doesn't print over the window right edge.

The HTML part requests no wrap for the text,
    <span style="font-size: 13px; ... white-space: pre-wrap; ">
thus I cannot do anything with that in the HTML part.

Nonetheless, we can backport at least the partial upstream fix [1] for anchors, which I committed for 3.11.1+ and 3.10.1+.

With respect of reproducer:
a) import test message from comment #0
b) in Edit->Preferences->Mail Preferences->HTML Messages->Plain Text Mode section 
   select "Show plain text if present"
c) view the imported message.

Before the change the text body is wider that the window width, after the change the text doesn't go beyond window width (down to certain size) and the URLs at the end are wrapped.

[1] https://git.gnome.org/browse/evolution/commit/?id=00005fe
Comment 5 Milan Crha 2013-10-09 10:27:17 EDT
*** Bug 876883 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Cepl 2014-02-13 08:51:39 EST
Yes, this seems to be fixed. Sample case can be opened in evolution-3.8.5-17.el7.x86_64

Thank you
Comment 8 Ludek Smid 2014-06-13 05:32:44 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.