Bug 864967 - RFE: Allow email addresses as usernames
RFE: Allow email addresses as usernames
Status: CLOSED WONTFIX
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 10:02 EDT by Justin Sherrill
Modified: 2015-03-22 21:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 15:43:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-10-10 10:02:55 EDT
Description of problem:

Within katello we want to allow users to use usernames of email addresses.  For this to work properly in katello pulp needs to support this as well.

I'm sure there is an RFC somewhere but good ole' wikipedia says these characters need to be allowed: 

!#$%&'*+-/=?^_`{|}~   for the username.  @ and '.' also need to be allowed.

http://en.wikipedia.org/wiki/E-mail_address#Valid_email_addresses
Comment 1 Tom McKay 2012-11-05 16:13:01 EST
This was originally requested for use with katello/headpin but is (or soon will be) unnecessary. Instead of using the same user name from katello/headpin, a sanitized version will be passed to pulp.

Leaving the status as NEW; leaving it up to pulp folks to decide if it's necessary for non-katello environments.
Comment 2 Jay Dobies 2012-11-27 15:43:00 EST
It's actually non-trivial due to a restriction in mongo. If this isn't needed for Katello, I'm closing this out since the work involved is reasonably extensive.

Note You need to log in before you can comment on or make changes to this bug.