Bug 865023 - CLI - delete org shows error
CLI - delete org shows error
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Bryan Kearney
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 12:14 EDT by Hayk Hovsepyan
Modified: 2014-09-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-18 09:38:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2012-10-10 12:14:02 EDT
Description of problem:
When you have created 2 templates one is child of another, It does not allow to delete organization.

Version-Release number of selected component (if applicable):
katello-configure-1.1.10-1.git.48.b44a09b.el6.noarch
katello-glue-candlepin-1.1.13-1.git.87.be28459.el6.noarch
katello-agent-1.1.2-1.el6.noarch
katello-repos-1.1.2-1.el6.noarch
katello-glue-pulp-1.1.13-1.git.87.be28459.el6.noarch
katello-selinux-1.1.2-1.el6.noarch
katello-1.1.13-1.git.87.be28459.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.1.9-1.git.51.edfca34.el6.noarch
katello-common-1.1.13-1.git.87.be28459.el6.noarch
katello-glue-foreman-1.1.13-1.git.87.be28459.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.1.9-1.git.51.edfca34.el6.noarch
katello-certs-tools-1.1.8-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create organization.
2. Create template in that org.
3. Create child template to first template.
4. Try to delete organization by CLI. It will show error "Organization [ test ] deletion failed: The template has children templates". Which is bug. 
  
Actual results: 
Error is thrown.

Expected results:
It should delete organization.

Additional info:
When just deleting parent template it shows the same error which is correct.
Comment 1 Miroslav Suchý 2012-10-10 17:09:05 EDT
Hayk,
can you elaborate why do you think this is bug? It seems as correct behaviour to me.
Comment 2 Hayk Hovsepyan 2012-10-11 03:48:44 EDT
Both templates are related to only that organization, and when we do not need this organization we do not need those templates anymore, as they can not be applied to other organizations.
Similar behaviour is when we delete promoted repo, it shows error. But when we delete that repo's organization, it deletes that repos, environments and whole stuff related to that organization without checks.
So when we delete organization it should force delete all entities (repo, environment, template, provider ....) related to that org.
Comment 3 Miroslav Suchý 2012-12-04 08:03:26 EST
Discussed here:
https://www.redhat.com/archives/katello-devel/2012-November/msg00003.html
Comment 4 Miroslav Suchý 2012-12-04 08:14:07 EST
Ignore #3
Comment 6 Mike McCune 2013-08-16 14:01:14 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 7 Bryan Kearney 2014-02-18 09:38:21 EST
this is against the katello-cli which we are not using any more, closing.

Note You need to log in before you can comment on or make changes to this bug.