Bug 865109 - [abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:933 assert_pch_pll+0x18f/0x1f0 [i915](): TAINTED G W
[abrt]: WARNING: at drivers/gpu/drm/i915/intel_display.c:933 assert_pch_pll+0...
Status: CLOSED DUPLICATE of bug 862360
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:b8c005fd7d56a54c2865e357072...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 16:31 EDT by Brad Hubbard
Modified: 2013-01-22 15:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 15:24:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hubbard 2012-10-10 16:31:01 EDT
Description of problem:
After a wake from Sleep and during the reconfiguration of monitors. looks like a slow path in the i915 driver.

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.4-2.fc17.x86_64 root=/dev/mapper/vg-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us SYSFONT=True rd.lvm.lv=vg/lv_root rd.luks.uuid=luks-b204195b-f259-42ce-9705-f093a7e44ace rd.lvm.lv=vg/lv_swap LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.4-2.fc17.x86_64

kernel_tainted_long:
:Proprietary module has not been loaded.
:Taint on warning.

backtrace:
:WARNING: at drivers/gpu/drm/i915/intel_display.c:933 assert_pch_pll+0x18f/0x1f0 [i915]()
:Hardware name: 4243BQ3
:PCH PLL state for reg c6014 assertion failure (expected on, current off), val=04800080
:Modules linked in: usb_storage fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle lockd sunrpc bridge stp llc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi xfs snd_hda_codec_hdmi snd_hda_codec_conexant uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media arc4 btusb snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer bluetooth iwlwifi mac80211 cfg80211 e1000e lpc_ich mei i2c_i801 mfd_core coretemp microcode thinkpad_acpi snd soundcore rfkill vhost_net tun macvtap macvlan kvm_intel kvm uinput xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel firewire_ohci sdhci_pci sdhci firewire_core mmc
:_core crc_itu_t wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 25166, comm: kworker/u:14 Tainted: G        W    3.5.4-2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81058746>] warn_slowpath_fmt+0x46/0x50
: [<ffffffffa008f06f>] assert_pch_pll+0x18f/0x1f0 [i915]
: [<ffffffffa0094742>] ironlake_crtc_disable+0x4e2/0x840 [i915]
: [<ffffffffa0094b4e>] ironlake_crtc_prepare+0xe/0x10 [i915]
: [<ffffffffa0066f09>] drm_crtc_helper_set_mode+0x2c9/0x500 [drm_kms_helper]
: [<ffffffffa0077fe0>] ? snb_gt_irq_handler+0xc0/0xc0 [i915]
: [<ffffffffa00671b3>] drm_helper_resume_force_mode+0x73/0x170 [drm_kms_helper]
: [<ffffffffa00188cd>] ? drm_irq_install+0x14d/0x270 [drm]
: [<ffffffffa006f1ac>] i915_drm_thaw+0xcc/0x150 [i915]
: [<ffffffffa006f39e>] i915_resume+0x4e/0x80 [i915]
: [<ffffffffa006f426>] i915_pm_resume+0x16/0x20 [i915]
: [<ffffffff812f7a03>] pci_pm_resume+0x73/0xd0
: [<ffffffff812f7990>] ? pci_pm_restore+0xd0/0xd0
: [<ffffffff813bccf8>] dpm_run_callback+0x58/0x90
: [<ffffffff813bd452>] device_resume+0x112/0x250
: [<ffffffff813bd5b1>] async_resume+0x21/0x50
: [<ffffffff810830d3>] async_run_entry_fn+0x83/0x160
: [<ffffffff81075fc9>] process_one_work+0x129/0x400
: [<ffffffff81083050>] ? async_schedule+0x20/0x20
: [<ffffffff810765f6>] worker_thread+0x126/0x2e0
: [<ffffffff810764d0>] ? rescuer_thread+0x1f0/0x1f0
: [<ffffffff8107b633>] kthread+0x93/0xa0
: [<ffffffff816161e4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107b5a0>] ? flush_kthread_worker+0x80/0x80
: [<ffffffff816161e0>] ? gs_change+0x13/0x13
Comment 1 Brad Hubbard 2012-10-10 16:49:27 EDT
The line prior may be relevant. 

[85964.988474] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off

Here's the code.

    911 /* For ILK+ */
    912 static void assert_pch_pll(struct drm_i915_private *dev_priv,
    913                            struct intel_pch_pll *pll,
    914                            struct intel_crtc *crtc,
    915                            bool state)
    916 {
    917         u32 val;
    918         bool cur_state;
    919 
    920         if (HAS_PCH_LPT(dev_priv->dev)) {
    921                 DRM_DEBUG_DRIVER("LPT detected: skipping PCH PLL test\n");
    922                 return;
    923         }
    924 
    925         if (WARN (!pll,
    926                   "asserting PCH PLL %s with no PLL\n", state_string(state)))
    927                 return;
    928 
    929         val = I915_READ(pll->pll_reg);
    930         cur_state = !!(val & DPLL_VCO_ENABLE);
    931         WARN(cur_state != state,
    932              "PCH PLL state for reg %x assertion failure (expected %s, current %s), val=%08x\n",
    933              pll->pll_reg, state_string(state), state_string(cur_state), val);   <--- HERE
Comment 2 Adam Jackson 2013-01-22 15:24:23 EST

*** This bug has been marked as a duplicate of bug 862360 ***

Note You need to log in before you can comment on or make changes to this bug.