Bug 865191 - 'Software selection' spoke gets the warning triangle if you leave it on the default (GNOME) and change the 'installation source'
'Software selection' spoke gets the warning triangle if you leave it on the d...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-10 20:34 EDT by Adam Williamson
Modified: 2012-10-11 10:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 10:53:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-10-10 20:34:10 EDT
To reproduce: boot F18 Beta TC3 DVD, to the hub screen. Note the 'software selection' spoke has 'GNOME desktop environment' pre-selected, and doesn't have the 'warning triangle', i.e., you aren't required to go through it, you can proceed with installation without going into that spoke.

Now go into the 'installation source' spoke and change the source from DVD to 'nearest mirror' (on the network), and return to hub.

Now the 'software selection' spoke has the warning triangle, and you can't proceed with install without going into it. But why? 'GNOME desktop environment' is still listed as being selected, and anaconda should be perfectly capable of selecting the packages from that group from the remote repository (instead of the DVD) for installation. There's no valid reason I can see to suddenly require user interaction where none was required before.

'low' severity as this is really just an inconvenience, doesn't break the install or anything.
Comment 1 Chris Lumens 2012-10-10 22:41:44 EDT
Once you've changed your installation source, though, you've fetched a new set of repo metadata.  This could be completely different from what was originally fetched, and the package selections could be anywhere from completely valid to partially valid to completely invalid.

We try to apply your selections to the new repo metadata, but who knows how successful we'll be.  Once you've made this change, you really do need to go back and double check everything's still as you want it.

You're only lucky because you know what you're doing and chose another similar Fedora tree.  Other people will not be as lucky.
Comment 2 Adam Williamson 2012-10-10 22:48:44 EDT
well I see the theoretical point, but are there really cases where people pick a remote package source that's that far incompatible with the official repos?
Comment 3 Chris Lumens 2012-10-11 10:43:11 EDT
I am positive that anything people can do, they will do.

Note You need to log in before you can comment on or make changes to this bug.