This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865409 - No deprecated warning message is shown when using rhc app cartridge
No deprecated warning message is shown when using rhc app cartridge
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: John Keck
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 07:28 EDT by joycezhang
Modified: 2015-05-14 22:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.99.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-15 10:18:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-10-11 07:28:12 EDT
Description of problem:
No deprecated warning message is shown when using old command rhc app cartridge

# rhc app cartridge
Password: *


RESULT:
mongodb-2.2, cron-1.4, mysql-5.1, postgresql-8.4, haproxy-1.4, 10gen-mms-agent-0.1, phpmyadmin-3.4, metrics-0.1, phpmoadmin-1.0, rockmongo-1.1,
jenkins-client-1.4

Version-Release number of selected component (if applicable):
fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_226

How reproducible:
always

Steps to Reproduce:
1.rhc app cartridge
2.
3.
  
Actual results:
No deprecated warning message is shown 

Expected results:
Deprecated warning message should be shown with this old command.

Additional info:
Comment 1 Peter Ruan 2012-10-16 19:19:20 EDT
deprecated warning message is still not shown in rhc 0.99.7



[pruan@homer-linux <MASTER> .openshift]# rhc app cartridge -pvostok08 

RESULT:
mongodb-2.2, cron-1.4, mysql-5.1, postgresql-8.4, haproxy-1.4, 10gen-mms-agent-0.1, phpmyadmin-3.4, metrics-0.1,
phpmoadmin-1.0, rockmongo-1.1, jenkins-client-1.4

[pruan@homer-linux <MASTER> .openshift]#
Comment 2 Rony Gong 2013-01-25 04:08:30 EST
Rest it on rhc-1.3.8 fixed, please mark this bug to ON_QA, thank you!
[qgong@localhost dev]$ rhc app cartridge 
Warning: This command is deprecated. Please use 'rhc cartridge' instead. For porting and testing purposes you may switch this a warning to an error by setting the DISABLE_DEPRECATED environment
variable to 1.  It is not recommended to do so in a production environment as this option will be removed in a future release.
Comment 3 joycezhang 2013-02-16 20:45:18 EST
Verified this bug with rhc-1.4.8.gem, deprecated message is shown when using the old command "rhc app cartridge" as below:

# rhc app cartridge
Warning: This command is deprecated. Please use 'rhc cartridge' instead. For porting and testing
purposes you may switch this a warning to an error by setting the DISABLE_DEPRECATED environment
variable to 1.  It is not recommended to do so in a production environment as this option will be
removed in a future release.

jbossas-7           JBoss Application Server 7.1              web
jbosseap-6.0        JBoss Enterprise Application Platform 6.0 web
jenkins-1.4         Jenkins Server 1.4                        web
nodejs-0.6          Node.js 0.6                               web
perl-5.10           Perl 5.10                                 web
php-5.3             PHP 5.3                                   web
python-2.6          Python 2.6                                web
python-2.7          Python 2.7 Community Cartridge            web
python-3.3          Python 3.3 Community Cartridge            web
ruby-1.8            Ruby 1.8                                  web
ruby-1.9            Ruby 1.9                                  web
jbossews-1.0        Tomcat 6 (JBoss EWS 1.0)                  web
jbossews-2.0        Tomcat 7 (JBoss EWS 2.0)                  web
zend-5.6            Zend Server 5.6                           web
diy-0.1             Do-It-Yourself                            web
10gen-mms-agent-0.1 10gen Mongo Monitoring Service Agent 0.1  addon
cron-1.4            Cron 1.4                                  addon
jenkins-client-1.4  Jenkins Client 1.4                        addon
mongodb-2.2         MongoDB NoSQL Database 2.2                addon
mysql-5.1           MySQL Database 5.1                        addon
metrics-0.1         OpenShift Metrics 0.1                     addon
haproxy-1.4         OpenShift Web Balancer                    addon
phpmyadmin-3.4      phpMyAdmin 3.4                            addon
postgresql-8.4      PostgreSQL Database 8.4                   addon
rockmongo-1.1       RockMongo 1.1                             addon
switchyard-0.6      SwitchYard 0.6                            addon

-- press enter/return to continue or q to stop -- 




Note: Web cartridges can only be added to new applications.

Note You need to log in before you can comment on or make changes to this bug.