Bug 865415 - Errai: deployment of the errai-jpa-demo-basic example logs guava related errors
Errai: deployment of the errai-jpa-demo-basic example logs guava related errors
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Errai (Show other bugs)
2.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: 2.4.0
Assigned To: Pavel SLegr
Stefan Miklosovic
errai-example
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 07:43 EDT by Stefan Miklosovic
Modified: 2015-08-02 19:41 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:33:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
errai jpa basic error log (3.02 KB, text/plain)
2012-11-12 07:59 EST, Karel Piwko
no flags Details

  None (edit)
Description Stefan Miklosovic 2012-10-11 07:43:51 EDT
Description of problem:

Deployment of the jboss-wfk-2.1.0.ER1/demo/errai-2.1.0.CR2-redhat-1/jpa-examples/errai-jpa-demo-basic to JBoss AS 7 is impossible. 

Bug was reported here (1) https://community.jboss.org/thread/206514?tstart=0.
jfuerth took care of it and repaired it in github https://github.com/errai/errai/commit/3a4cde4b283d3bacf18638e7363fbad60b4b024a

Version-Release number of selected component (if applicable):
errai-2.1.0.CR2-redhat-1

How reproducible:
always

Steps to Reproduce:
1. creating maven project which tries to build the parent (by mvn invoker plugin)
2. deployment of the war file to the jboss as 7
3. seeing the error message (1) 
  
Actual results:
unsuccessful deployment

Expected results:
taking these changes and integrate them to the next wfk ER release. (to ER2, if possible) and be able to reproduce successful deployment afterwards

Additional info:
Comment 1 Pavel SLegr 2012-10-11 07:53:45 EDT
Shouldn't this example of jboss-wfk-2.1.0.ER1/demo/errai-2.1.0.CR2-redhat-1/jpa-examples/errai-jpa-demo-basic be tested for deployment on EAP-6.0.0.GA ? 
Or did you actually mean EAP but declared AS instead ?
Comment 2 Stefan Miklosovic 2012-10-11 08:35:47 EDT
I really meant JBoss AS 7 but after your suggestion I can reproduce that bug as well on EAP 6.0.0

(In reply to comment #1)
> Shouldn't this example of
> jboss-wfk-2.1.0.ER1/demo/errai-2.1.0.CR2-redhat-1/jpa-examples/errai-jpa-
> demo-basic be tested for deployment on EAP-6.0.0.GA ? 
> Or did you actually mean EAP but declared AS instead ?
Comment 3 Pavel SLegr 2012-10-11 08:38:06 EDT
What figured out from Jonathan's reply on that relevant upstream issue was there needs to be excluded persistence.xml file only.
Pushing this fix into WFK-2.1.0-ER2 ... please once jboss-wfk-2.1.0.ER2 with fixed demo is available try to deploy on EAP-6.0.0.GA...
Comment 4 Jonathan Fuerth 2012-10-11 10:00:18 EDT
Yes, but I also changed the scope of javassist to compile (was provided) because JBoss Modules wasn't exposing it (or at least not the right version) to the app. I also excluded a bunch of libs in the "jboss7" profile because those ones ARE provided by the appserver.

Some notes:

1. This demo is strictly for client-side functionality, so as long as the build works and the server can serve the html+js+css files, the demo will work.

2. I will apply similar changes to errai-jpa-demo-grocery-list, because it has a similar problem.

3. If you guys know a better way to exclude provided libs within a profile (rather than listing them all explicitly), please let me know (maybe on errai-dev?). The current approach is a maintenance disaster! :)
Comment 5 Marek Novotny 2012-10-15 04:04:17 EDT
This is partially fixed as a source is Jonathan's comment - errai-jpa-demo-grocery-list is not in ER2 fixed. Anyway please verify both in ER2 QA cycle.
Comment 6 Stefan Miklosovic 2012-10-17 08:01:32 EDT
Deployment of the demos in the errai-jpa distribution (errai-jpa-demo-basic  and errai-jpa-demo-grocery-list) at EAP 6.0.0.GA is still unsuccessful after successful building. Please investigate unmet dependecies while deploying to the EAP 6.0.0.GA.
Comment 7 Pavel SLegr 2012-10-18 09:32:43 EDT
just updating on progress... 
 - I've cleaned out examples for all * WFK unwanted* profiles.
 - and fixed deployment for Jboss7 (EAP6)
Now I am able to deploy and example running on my local just fine... 
Additionally there showed up two more issues  
one with guava version ... this is something that I am fixing now
and another one is known bug https://issues.jboss.org/browse/AS7-5178
this will probably need to remain as known issue....
Comment 8 Pavel SLegr 2012-10-18 09:59:11 EDT
Fix with http://git.app.eng.bos.redhat.com/?p=errai/errai.git;a=commit;h=f748781936023cb5e95f670a1e5c5a82c6e25f0c

Stefan please check out fixed examples and try out against EAP-6.0.0 and with WFK21 ER2 build...

We need to make sure all examples goes into CR1 ready and working  !!!
thank you
Comment 10 Karel Piwko 2012-11-12 07:56:55 EST
Status for examples of 2.1.0.CR1:

jpa-basic - deployment on EAP 6.0.0 works, but following errors are emitted:

13:51:35,512 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-8) JBAS018567: Deployment "deployment.errai-jpa-demo-basic.war" is using a private module ("org.jboss.as.naming:main") which may be changed or removed in future versions without notice.
13:51:35,512 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-8) JBAS018567: Deployment "deployment.errai-jpa-demo-basic.war" is using a private module ("org.jboss.as.naming:main") which may be changed or removed in future versions without notice.
13:51:35,513 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-8) JBAS018567: Deployment "deployment.errai-jpa-demo-basic.war" is using a private module ("org.jboss.as.server:main") which may be changed or removed in future versions without notice.
13:51:35,513 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-8) JBAS018567: Deployment "deployment.errai-jpa-demo-basic.war" is using a private module ("org.jboss.as.server:main") which may be changed or removed in future versions without notice.
13:51:35,660 WARN  [org.jboss.as.ee] (MSC service thread 1-8) JBAS011006: Not installing optional component org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1 due to exception: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011054: Could not find default constructor for class org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1
        at org.jboss.as.ee.component.ComponentDescription$DefaultComponentConfigurator.configure(ComponentDescription.java:606) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:83) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:116) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_33]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_33]
        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_33]

13:51:35,719 INFO  [org.jboss.as.osgi] (MSC service thread 1-3) JBAS011907: Register module: Module "deployment.errai-jpa-demo-basic.war:main" from Service Module Loader
13:51:35,877 ERROR [stderr] (MSC service thread 1-2) java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
13:51:35,877 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
13:51:35,877 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.FutureTask.get(FutureTask.java:83)
13:51:35,877 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.ScannerSingleton.getOrCreateInstance(ScannerSingleton.java:53)
13:51:35,877 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.bus.server.service.ErraiServiceConfiguratorImpl.<init>(ErraiServiceConfiguratorImpl.java:55)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.bus.server.servlet.ServletBootstrapUtil.initService(ServletBootstrapUtil.java:73)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.bus.server.servlet.ServletBootstrapUtil.getService(ServletBootstrapUtil.java:45)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.bus.server.servlet.AbstractErraiServlet.init(AbstractErraiServlet.java:71)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1202)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1102)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3655)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.apache.catalina.core.StandardContext.start(StandardContext.java:3873)
13:51:35,878 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at java.lang.Thread.run(Thread.java:662)
13:51:35,879 ERROR [stderr] (MSC service thread 1-2) Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
13:51:35,879 ERROR [stderr] (MSC service thread 1-2)    at com.google.common.cache.LocalCache.<clinit>(LocalCache.java:155)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at com.google.common.cache.LocalCache$LocalManualCache.<init>(LocalCache.java:4750)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at com.google.common.cache.LocalCache$LocalLoadingCache.<init>(LocalCache.java:4858)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at com.google.common.cache.CacheBuilder.build(CacheBuilder.java:739)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.reflections.Store.<init>(Store.java:63)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.reflections.Store.<init>(Store.java:48)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.reflections.Reflections.<init>(Reflections.java:83)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.MetaDataScanner.<init>(MetaDataScanner.java:82)
13:51:35,880 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.MetaDataScanner.createInstance(MetaDataScanner.java:130)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.MetaDataScanner.createInstance(MetaDataScanner.java:118)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.ScannerSingleton$1.call(ScannerSingleton.java:38)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    at org.jboss.errai.common.metadata.ScannerSingleton$1.call(ScannerSingleton.java:31)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
13:51:35,881 ERROR [stderr] (MSC service thread 1-2)    ... 1 more
13:51:35,890 INFO  [org.jboss.web] (MSC service thread 1-2) JBAS018210: Registering web context: /errai-jpa-demo-basic
13:51:35,898 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "errai-jpa-demo-basic.war"
13:51:35,981 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
13:51:35,981 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) started in 3590ms - Started 176 of 258 services (81 services are passive or on-demand)
Comment 11 Karel Piwko 2012-11-12 07:59:09 EST
Created attachment 643493 [details]
errai jpa basic error log

A lot of following errors are emit into EAP6 console output when working with the example in the browser.

I expect this happens due to using of Guava module from EAP6, which is not 100% compatible with Errai.

Surprisingly, the example seem to work correctly
Comment 12 Karel Piwko 2012-11-12 08:02:57 EST
grocery-list - deploy, but following warnings are written during the deployment. The same sameThreadExecutor() warning are emitted for the example as for jpa-basic one:

13:59:44,745 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-3) JBAS015012: Started FileSystemDeploymentService for directory /opt/eap6/standalone/deployments
13:59:46,036 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-4) JBAS018567: Deployment "deployment.errai-jpa-demo-grocery-list.war" is using a private module ("org.jboss.as.naming:main") which may be changed or removed in future versions without notice.
13:59:46,037 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-4) JBAS018567: Deployment "deployment.errai-jpa-demo-grocery-list.war" is using a private module ("org.jboss.as.naming:main") which may be changed or removed in future versions without notice.
13:59:46,037 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-4) JBAS018567: Deployment "deployment.errai-jpa-demo-grocery-list.war" is using a private module ("org.jboss.as.server:main") which may be changed or removed in future versions without notice.
13:59:46,037 WARN  [org.jboss.as.dependency.private] (MSC service thread 1-4) JBAS018567: Deployment "deployment.errai-jpa-demo-grocery-list.war" is using a private module ("org.jboss.as.server:main") which may be changed or removed in future versions without notice.
13:59:46,172 WARN  [org.jboss.as.ee] (MSC service thread 1-7) JBAS011006: Not installing optional component org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1 due to exception: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011054: Could not find default constructor for class org.jboss.errai.bus.server.servlet.StandardAsyncServlet$1
        at org.jboss.as.ee.component.ComponentDescription$DefaultComponentConfigurator.configure(ComponentDescription.java:606) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:83) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:116) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_33]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_33]
        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_33]

13:59:46,235 INFO  [org.jboss.as.osgi] (MSC service thread 1-7) JBAS011907: Register module: Module "deployment.errai-jpa-demo-grocery-list.war:main" from Service Module Loader
13:59:46,379 ERROR [stderr] (MSC service thread 1-4) java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
13:59:46,380 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
13:59:46,380 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.FutureTask.get(FutureTask.java:83)
13:59:46,380 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.ScannerSingleton.getOrCreateInstance(ScannerSingleton.java:53)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.bus.server.service.ErraiServiceConfiguratorImpl.<init>(ErraiServiceConfiguratorImpl.java:55)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.bus.server.servlet.ServletBootstrapUtil.initService(ServletBootstrapUtil.java:73)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.bus.server.servlet.ServletBootstrapUtil.getService(ServletBootstrapUtil.java:45)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.bus.server.servlet.AbstractErraiServlet.init(AbstractErraiServlet.java:71)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1202)
13:59:46,381 ERROR [stderr] (MSC service thread 1-4)    at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1102)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3655)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at org.apache.catalina.core.StandardContext.start(StandardContext.java:3873)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
13:59:46,382 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at java.lang.Thread.run(Thread.java:662)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4) Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at com.google.common.cache.LocalCache.<clinit>(LocalCache.java:155)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at com.google.common.cache.LocalCache$LocalManualCache.<init>(LocalCache.java:4750)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at com.google.common.cache.LocalCache$LocalLoadingCache.<init>(LocalCache.java:4858)
13:59:46,383 ERROR [stderr] (MSC service thread 1-4)    at com.google.common.cache.CacheBuilder.build(CacheBuilder.java:739)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.reflections.Store.<init>(Store.java:63)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.reflections.Store.<init>(Store.java:48)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.reflections.Reflections.<init>(Reflections.java:83)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.MetaDataScanner.<init>(MetaDataScanner.java:82)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.MetaDataScanner.createInstance(MetaDataScanner.java:130)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.MetaDataScanner.createInstance(MetaDataScanner.java:118)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.ScannerSingleton$1.call(ScannerSingleton.java:38)
13:59:46,384 ERROR [stderr] (MSC service thread 1-4)    at org.jboss.errai.common.metadata.ScannerSingleton$1.call(ScannerSingleton.java:31)
13:59:46,385 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
13:59:46,385 ERROR [stderr] (MSC service thread 1-4)    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
13:59:46,385 ERROR [stderr] (MSC service thread 1-4)    ... 1 more
13:59:46,392 INFO  [org.jboss.web] (MSC service thread 1-4) JBAS018210: Registering web context: /errai-jpa-demo-grocery-list
13:59:46,404 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "errai-jpa-demo-grocery-list.war"
Comment 13 mark yarborough 2012-11-12 10:01:33 EST
CCFR from errai team.
Comment 15 Jonathan Fuerth 2012-11-13 12:26:00 EST
Cause: 
Errai requires version 12.0 or newer of the Google Guava library, but WFK and EAP have standardized on 11.0. The pom.xml for Errai's demos have been modified to use Guava 12.0 at compile time (when it is strictly required) and fall back to Guava 11.0 at runtime.

Consequence: 
The following error appears in the log when either of the Errai JPA demos are deployed: 

    ERROR [stderr] (MSC service thread 1-4) java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;

Fix: 
None.

Result:
It is possible to deploy Errai JPA demos as shipped, but this error will appear in the EAP log at .war deployment time.
Comment 19 Pavel SLegr 2013-04-15 09:59:28 EDT
Can not be any progressed until we move to EAP 6.1 - where guava version 12.0 is already present. Will be resolved right after WFK-2.3 productization begins

Note You need to log in before you can comment on or make changes to this bug.