Bug 865431 - rhevm-installation: ovirt-engine does not start automatically after rhevm host reboot on upgraded setup (from 3.0 to 3.1)
rhevm-installation: ovirt-engine does not start automatically after rhevm hos...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Alex Lourie
Ilanit Stein
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 08:54 EDT by Dafna Ron
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: si21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-23 06:31:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (165.75 KB, application/x-gzip)
2012-10-11 08:54 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-11 08:54:14 EDT
Created attachment 625500 [details]
logs

Description of problem:

on a setup that I upgraded from 3.0 to 3.1 I rebooted the rhevm host. 
when the host came up service ovirt-engine was stopped. 
looking at chkconfig we do not have ovirt-engine but we have jbossas:

[root@daffi-linux ~]# chkconfig --list |grep ovirt
[root@daffi-linux ~]# /etc/init.d/ovirt-engine status
The engine is not running.

[root@daffi-linux ~]# chkconfig --list |grep jboss
jbossas        	0:off	1:off	2:off	3:off	4:off	5:off	6:off

on a clean 3.1 chkconfig shows ovirt-engine: 

root@dafna-web-admin ~]# chkconfig --list |grep ovirt
ovirt-engine   	0:off	1:off	2:on	3:on	4:on	5:on	6:off

Version-Release number of selected component (if applicable):

si20 - upgraded from 3.0 

How reproducible:

100%

Steps to Reproduce:
1. upgrade 3.0 to 3.1 
2. reboot the rhevm host
3.
  
Actual results:

ovirt-engine is stopped after the reboot because chkconfig lists jbossas and not ovirt-engine. 

Expected results:

when upgrading we should change the jboosas in chkconfig to ovirt-engine

Additional info: full engine and jboss logs
Comment 3 Ilanit Stein 2012-12-17 08:48:33 EST
Verified on upgrade from ic158.2 to si25.1.

Note You need to log in before you can comment on or make changes to this bug.