Bug 865450 - Wrong listener classname for mod_cluster in tomcats
Wrong listener classname for mod_cluster in tomcats
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: doc-HTTP-Connectors-Guide (Show other bugs)
2.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 09:25 EDT by Radim Hatlapatka
Modified: 2012-11-08 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 17:11:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2012-10-11 09:25:41 EDT
Listener classname in web server worker nodes (tomcats) in EWS 2.0 is not
"org.jboss.modcluster.ModClusterListener" but it is "org.jboss.modcluster.container.catalina.standalone.ModClusterListener"

I see this issue at least in Procedure 8.2. Configure Web Server Worker Node with Static Proxy List
but check if there are not other occurrences as well.
Comment 1 Misha H. Ali 2012-10-11 17:58:47 EDT
Corrected in three places. There should now be now occurrences of org.jboss.modcluster.ModClusterListener and 3 occurrences of org.jboss.modcluster.container.catalina.standalone.ModClusterListener.
Comment 2 Misha H. Ali 2012-11-08 17:11:26 EST
This bug is set to CLOSED CURRENT RELEASE to indicate that this fix is now released and available at access.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.