Bug 86550 - Updated packages for 7x do not satisfy old lib dependencies
Updated packages for 7x do not satisfy old lib dependencies
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-25 07:53 EST by Jon Burgess
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-28 14:43:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2003-03-25 07:53:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I tried updating to the latest test RPM packages for 7x on a RH-7.3 system and
it fails to install because it does not provide librpm-4.0.4.so required by a
number of other packages.

Version-Release number of selected component (if applicable):
rpm-4.1.1-1.7x.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Downloaded new rpm packages from
ftp://ftp.rpm.org/pub/rpm/test-4.1.1/*7x.i386.rpm
2. rpm -Fvh <new rpms>

Actual Results:  [root@vectra rpm]# rpm -Fvh *7x.i386.rpm
error: failed dependencies:
        librpm-4.0.4.so   is needed by kdeadmin-3.0.3-0.7
        librpm-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpm-4.0.4.so   is needed by ucd-snmp-utils-4.2.5-7.73.0
        librpmbuild-4.0.4.so   is needed by kdeadmin-3.0.3-0.7
        librpmdb-4.0.4.so   is needed by kdeadmin-3.0.3-0.7
        librpmdb-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmdb-4.0.4.so   is needed by ucd-snmp-utils-4.2.5-7.73.0
        librpmio-4.0.4.so   is needed by kdeadmin-3.0.3-0.7
        librpmio-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmio-4.0.4.so   is needed by ucd-snmp-utils-4.2.5-7.73.0


Expected Results:  It should have updated OK

Additional info:

It looks like there need to be some 7.x versions of the rpm404 compatibility
rpms shipped with RH8
Comment 1 Jeff Johnson 2003-03-28 14:43:50 EST
Yes, rpm-4.1.1 does not supply rpm-4.0.4 libraries,
but is being made available in case people wish to use
rpm-4.2 code base on Red Hat 7.3.

If you want to use rpm-4.1.1 on Red Hat 7.3, all the missing
dependencies would have to be supplied, basically by install
(or back porting) the Red Hat 8.0 version.

Note You need to log in before you can comment on or make changes to this bug.