Bug 865530 - gnome-control-center is broken when started as root
gnome-control-center is broken when started as root
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
: 866367 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 13:02 EDT by Martin Kolman
Modified: 2012-10-15 04:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-12 03:52:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kolman 2012-10-11 13:02:23 EDT
Description of problem:
when running under root no settings take effect

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start a root console
2. starto gnome-control-center from the root console
3. try to change some setting
  
Actual results:
no changes take effect, some widgets look broken

Expected results:
all changes take effect

Additional info:
Comment 1 Bastien Nocera 2012-10-12 03:52:00 EDT
(In reply to comment #0)
> Description of problem:
> when running under root no settings take effect
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. start a root console
> 2. starto gnome-control-center from the root console
> 3. try to change some setting
>   
> Actual results:
> no changes take effect, some widgets look broken
> 
> Expected results:
> all changes take effect

They won't. Why would you start the settings as root?
It's broken because:
- You don't have a session D-Bus, so dconf cannot start, so you don't have any storage for the settings
- You're changing the root's config, not your user's
- The widgets look broken because the themes can't be found.

Don't do that. If you want to discuss why you're doing this and you think you have a valid reason to, file a bug upstream.
Comment 2 Bastien Nocera 2012-10-15 04:47:04 EDT
*** Bug 866367 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.