Bug 865559 - [IE] every page seems displays unsecured content being delievered error
[IE] every page seems displays unsecured content being delievered error
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: beta6
: ---
Assigned To: Brian McLaughlin
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 14:31 EDT by Dave Johnson
Modified: 2012-12-04 10:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Every page displayed an "unsecured content being delivered" error when using the Internet Explorer browser. As a result, users were queried on every page if they wanted to receive unsecured content across HTTP. This fix moves all of the content over to be delivered through HTTPS connection. No such queries are seen on Internet Explorer now.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:08:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2012-10-11 14:31:09 EDT
Description of problem:
=================================
When using the IE browser, users are queried on every page if they want to received unsecured content coming across http.  The user could disable this in IE properties but it makes their browser less secure.  We need to move all of our content over to be delivered through https connection.
Comment 1 Brian McLaughlin 2012-10-12 10:29:49 EDT
Patch posted to list, "[PATCH conductor] Bug 865559 - [IE] every page seems displays unsecured content being delievered error".
Comment 2 Matt Wagner 2012-10-12 16:16:20 EDT
Pushed to master and 1.1:

commit d60add961a0db0187ba3c37748f2389ed87cad49
Author: Brian McLaughlin <bmclaugh@redhat.com>
Date:   Fri Oct 12 10:27:22 2012 -0400

    Remove security error on every page in IE
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
    (cherry picked from commit a6163ab17b50797d85a65cdd41fb5b48065286e5)
Comment 4 Shveta 2012-10-24 17:01:59 EDT
No such queries are seen on IE now..

 rpm -qa|grep aeolus
aeolus-configure-2.8.9-1.el6cf.noarch
aeolus-conductor-0.13.21-1.el6cf.noarch
rubygem-aeolus-cli-0.7.6-1.el6cf.noarch
aeolus-conductor-doc-0.13.21-1.el6cf.noarch
aeolus-all-0.13.21-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.21-1.el6cf.noarch
Comment 6 errata-xmlrpc 2012-12-04 10:08:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.