This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 865564 - don't minimize dracut config
don't minimize dracut config
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 14:59 EDT by Mike Burns
Modified: 2013-02-28 11:32 EST (History)
8 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
The dracut configuration which generates the initrd file was being stripped out of the build. This resulted in errors when the ovirt-boot-functions were being loaded. This fix prevents the minimizing of the dracut configuration and also fixes the sourcing of the dracut functions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:32:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-10-11 14:59:45 EDT
Description of problem:
currently we minimize dracut config which leads to a lot of errors about being able to load ovirt-boot-functions.

Version-Release number of selected component (if applicable):
ovirt-node-2.5.0-5.el6

How reproducible:
always

Steps to Reproduce:
1.boot rhev-h
2.
3.
  
Actual results:
errors about failing to load ovirt-boot-functions

Expected results:
no errors

Additional info:
Comment 3 haiyang,dong 2012-10-31 03:16:08 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

[root@localhost admin]# find / -name "ovirt-boot-functions"
/usr/share/dracut/modules.d/91ovirtnode/ovirt-boot-functions

check that the "ovirt-boot-functions" in the folder "/usr/share/dracut/modules.d/91ovirtnode"

so this bug has been fixed, change the status into "VERIFIED"
Comment 4 haiyang,dong 2012-12-26 06:44:12 EST
so follow steps of comment 3 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 6 errata-xmlrpc 2013-02-28 11:32:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.