Bug 86562 - httpd-manual files installed in inconvenient location
httpd-manual files installed in inconvenient location
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-25 12:23 EST by Robert P. J. Day
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-25 14:36:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2003-03-25 12:23:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
  this RPM installs all of the online HTML-format documentation
in the directory /var/www/manual.  this seems to be a bad idea,
since it's not available under the default DocumentRoot value,
so that you can't browse via the apache server itself.

  the reason this is inconvenient is that many of those files
have .en suffixes (among others), and require apache's content
negotiation to be able to follow hyperlinks.

  just browsing via a browser to file:///var/www/manual fails
pretty quickly because of this.  it would seem more reasonable
for these files to be installed under /var/www/html, or at least
for a post-install script to add a symlink to support this.

  as it is, the online HTML docs installed from this RPM
are simply not browseable.

Version-Release number of selected component (if applicable):
httpd-manual-2.0.40-8

How reproducible:
Always

Steps to Reproduce:
1.  browse to file:///var/www/manual
2.  try to follow some of the hyperlinks
3.  note that this fails due to files ending with ".html.en", which
disagrees with the names in the hyperlinks
    

Expected Results:  being able to browse, of course

Additional info:
Comment 1 Joe Orton 2003-03-25 14:36:15 EST
The default httpd.conf has:

Alias /manual "/var/www/manual"

so you can browse to http://localhost/manual/ to view the manual.


Note You need to log in before you can comment on or make changes to this bug.