Bug 865689 - "Recovery found" logs of wrong severity
"Recovery found" logs of wrong severity
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
2.2
All Linux
medium Severity low
: 3.0
: ---
Assigned To: Chuck Rolke
Irina Boverman
: EasyFix, Patch
Depends On:
Blocks: 785156
  Show dependency treegraph
 
Reported: 2012-10-12 03:03 EDT by Pavel Moravec
Modified: 2014-09-24 11:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-4.el6, qpid-cpp-0.22-4.el5
Doc Type: Bug Fix
Doc Text:
An issue with journal recovery messages reported at the WARN level caused customers to assume that action on their part was required to fix the issue when this was not the case. The fix lowers the priority of the recovery messages to INFO level, which sets the appropriate log level for this normal provisioning setting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-24 11:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trivial patch (1.07 KB, patch)
2012-10-12 03:05 EDT, Pavel Moravec
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4736 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 15:00:06 EDT

  None (edit)
Description Pavel Moravec 2012-10-12 03:03:39 EDT
Description of problem:
During journals recovery, two "Recovery found" types of log can be printed (see Actual results), with warning severity.

These logs should have lower severity (recommending info), as they occur when #files or file size differs from default. And it is normal to provision a journal with non-default parameters, thus info level is more appropriate than warning.


Version-Release number of selected component (if applicable):
any (incl. qpid-cpp-*-0.14-22 for MRG 2.2)


How reproducible:
100%


Steps to Reproduce:
1. qpid-config add queue DurableQueue --durable --file-count=16 --file-size=512
2. restart qpidd
3. check logs
  

Actual results:
2012-10-12 08:52:05 warning Journal "Durable": Recovery found 16 files (different from --num-jfiles value of 8).
2012-10-12 08:52:05 warning Journal "Durable": Recovery found file size = 1024 (different from --jfile-size-pgs value of 24).


Expected results:
"warning" replaced by "info" severity
(note that to see info logs, one has to set log-level=info+)


Additional info:
trivial patch attached
Comment 1 Pavel Moravec 2012-10-12 03:05:13 EDT
Created attachment 625828 [details]
trivial patch
Comment 2 Chuck Rolke 2013-04-17 16:18:07 EDT
Fixed upstream in qpid-legacystore component at Committed revision 1469054.

Note this is NOT fixed upstream in the jboss.org rhmessaging store repository.
Comment 4 Irina Boverman 2013-08-05 15:10:52 EDT
Installed packages:
---
perl-qpid-0.22-5.el6.x86_64
python-qpid-0.22-4.el6.noarch
qpid-java-example-0.22-5.el6.noarch
qpid-qmf-0.22-7.el6.x86_64
qpid-java-common-0.22-5.el6.noarch
qpid-cpp-server-xml-0.22-8.el6.x86_64
qpid-cpp-debuginfo-0.22-8.el6.x86_64
python-qpid-proton-doc-0.4-2.2.el6.x86_64
qpid-tests-0.22-4.el6.noarch
qpid-cpp-server-0.22-8.el6.x86_64
qpid-cpp-client-rdma-0.22-8.el6.x86_64
qpid-cpp-server-ssl-0.22-8.el6.x86_64
qpid-cpp-server-devel-0.22-8.el6.x86_64
python-qpid-qmf-0.22-7.el6.x86_64
rh-qpid-cpp-tests-0.22-8.el6.x86_64
qpid-proton-c-0.4-2.2.el6.x86_64
qpid-tools-0.22-3.el6.noarch
qpid-snmpd-debuginfo-1.0.0-12.el6.x86_64
qpid-cpp-client-0.22-8.el6.x86_64
qpid-cpp-client-devel-0.22-8.el6.x86_64
qpid-cpp-client-ssl-0.22-8.el6.x86_64
qpid-cpp-server-rdma-0.22-8.el6.x86_64
qpid-proton-c-devel-0.4-2.2.el6.x86_64
qpid-proton-debuginfo-0.4-2.2.el6.x86_64
perl-qpid-debuginfo-0.22-5.el6.x86_64
qpid-cpp-server-store-0.22-8.el6.x86_64
qpid-cpp-client-devel-docs-0.22-8.el6.noarch
qpid-qmf-debuginfo-0.22-7.el6.x86_64
qpid-java-client-0.22-5.el6.noarch
ruby-qpid-qmf-0.22-7.el6.x86_64
qpid-cpp-server-ha-0.22-8.el6.x86_64
python-qpid-proton-0.4-2.2.el6.x86_64
qpid-qmf-devel-0.22-7.el6.x86_64
---
qpid-qmf-debuginfo-0.22-7.el6.i686
qpid-cpp-client-rdma-0.22-8.el6.i686
qpid-cpp-server-xml-0.22-8.el6.i686
qpid-proton-c-devel-0.4-2.2.el6.i686
qpid-java-client-0.22-5.el6.noarch
qpid-cpp-server-0.22-8.el6.i686
qpid-cpp-server-rdma-0.22-8.el6.i686
qpid-tools-0.22-3.el6.noarch
qpid-java-example-0.22-5.el6.noarch
qpid-cpp-tar-0.22-8.el6.noarch
qpid-qmf-0.22-7.el6.i686
ruby-qpid-qmf-0.22-7.el6.i686
qpid-qmf-devel-0.22-7.el6.i686
python-qpid-qmf-0.22-7.el6.i686
qpid-cpp-server-ha-0.22-8.el6.i686
python-qpid-0.22-4.el6.noarch
qpid-tests-0.22-4.el6.noarch
qpid-cpp-client-devel-docs-0.22-8.el6.noarch
qpid-snmpd-debuginfo-1.0.0-12.el6.i686
qpid-cpp-client-devel-0.22-8.el6.i686
qpid-cpp-server-devel-0.22-8.el6.i686
qpid-snmpd-1.0.0-12.el6.i686
perl-qpid-0.22-5.el6.i686
qpid-java-common-0.22-5.el6.noarch
qpid-cpp-client-0.22-8.el6.i686
qpid-cpp-server-ssl-0.22-8.el6.i686
rh-qpid-cpp-tests-0.22-8.el6.i686
qpid-proton-c-0.4-2.2.el6.i686
qpid-proton-debuginfo-0.4-2.2.el6.i686
qpid-cpp-debuginfo-0.22-8.el6.i686
qpid-cpp-client-ssl-0.22-8.el6.i686
qpid-cpp-server-store-0.22-8.el6.i686
Comment 5 errata-xmlrpc 2014-09-24 11:04:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.