Bug 865703 - Dracut module isn't working
Dracut module isn't working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 04:02 EDT by Fabian Deutsch
Modified: 2013-02-28 11:33 EST (History)
9 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously, running a reinstallation of Red Hat Enterprise Virtualization Hypervisor failed with "No volume groups found" because the previously created Host VG was still present in the system. This was due to the filesystem layout change in the dracut module which did not take into account that the RHEL6 dracut module was still using the old filesytem layout. This patch adds backward compatability for dracut in RHEL6 by adding the required files.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:33:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-10-12 04:02:10 EDT
Description of problem:
The dracut module (for cleaning up HostVG etc) isn't working properly.
Comment 3 Fabian Deutsch 2012-10-12 05:05:19 EDT
This lead to problems when running a reinstall, as the previosuly created HostVG wouldn't be removed
Comment 8 Mike Burns 2012-10-14 20:50:18 EDT
patch adds bashisms to ovirt-cleanup.sh which is /bin/sh.
Comment 11 haiyang,dong 2012-10-29 01:34:25 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Steps:
1. Install RHEVH
2. Boot again same RHEVH ISO
3. Select "Reinstall" option
4. When  the installer comes up and offers to "Install Hypervisor 6.4-20121015.1.el6" press F2, drop to shell,
5. run: vgs - "No volume groups found" is displayed
[root@localhost /]#vgs
No volume groups found


so this bug has been fixed.
Comment 12 haiyang,dong 2012-12-26 06:28:20 EST
so follow steps of comment 11 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 14 errata-xmlrpc 2013-02-28 11:33:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.