Bug 865726 - Traceback when getting test run build
Traceback when getting test run build
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: python-nitrate (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šplíchal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 05:16 EDT by Petr Šplíchal
Modified: 2016-05-31 21:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 06:08:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2012-10-12 05:16:04 EDT
Description of problem:
>>> print TestRun(47717).build
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/nitrate/api.py", line 192, in getter
    self._get()
  File "/usr/lib/python2.6/site-packages/nitrate/api.py", line 2682, in _get
    self._build = Build(testrunhash["build_id"])
KeyError: 'build_id'

Version-Release number of selected component (if applicable):
python-nitrate-0.9-0.el6.noarch
Comment 1 Petr Šplíchal 2012-12-06 06:08:52 EST
Looks like this has been fixed on the server side:

>>> print TestRun(47717).build
[INFO] Fetching test run TR#47717
[DEBUG] Initializing test run TR#47717
[DEBUG] {'auto_update_run_status': False,
 'build': 'unspecified',
 'build_id': 1156,
 'case_run_status': '2:65',
...

The 'build_id' key is now present in the testrunhash.

Note You need to log in before you can comment on or make changes to this bug.