Bug 865746 - Need to update "rhc app status" to "rhc app show --state" in many help files
Need to update "rhc app status" to "rhc app show --state" in many help files
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Hiro Asari
libra bugs
:
: 867637 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 06:10 EDT by Rony Gong
Modified: 2015-05-14 22:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 19:48:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-10-12 06:10:17 EDT
Description of problem:
Since rhc app status is deprecated, and replaced by rhc app show --state
so the help in rhc app -h need update.
some -n optiton explantion in rhc app start/git-clone/force-stop/restart/reload/stop/show/tidy/status/ -h  also need be updated.


Version-Release number of selected component (if applicable):
devenv_2318
client rhc-0.99.5.gem(build from fork_226)

How reproducible:
always

Steps to Reproduces
1. rhc app start/git-clone/force-stop/restart/reload/stop/show/tidy/status/ -h
2. rhc snapshot restore -h
3. rhc app -h
  
Actual results:
openshift@openshift-ubuntu:~/rhc$ rhc app start/git-clone/force-stop/restart/reload/stop/show/tidy/status/ -h
Usage: rhc app tidy <app> [--namespace namespace] [--app app]

Clean out the application's logs and tmp directories and tidy up the git repo on the server

Options for app tidy
  -n, --namespace namespace Namespace of the application the cartridge belongs to
  -a, --app app             The name of the application you are tidying

please update the explantion of -n option to 
Namespace of the application belong to
----------------------------------------------------------------
openshift@openshift-ubuntu:~/rhc$ rhc app delete -h
Usage: rhc app delete <app> [--namespace namespace]

Deletes your application and all of its data from the server. Use with caution as this operation is permanent.

Options for app delete
  -n, --namespace namespace Namespace to add your application to
  -b, --bypass              DEPRECATED Please use '--confirm'
  --confirm                 Deletes the application without prompting the user
  -a, --app name            The application you wish to delete

please update the explantion of -n option to 
Namespace of the application belong to
----------------------------------------------------------------
openshift@openshift-ubuntu:~/rhc$ rhc snapshot restore -h
Usage: rhc snapshot restore <application>

Restores a previously saved snapshot.

Options for snapshot restore
  -n, --namespace namespace Namespace of the application you are saving a snapshot
  -f, --filepath filepath   Local path to save tarball (default: ./$APPNAME.tar.gz)
  -a, --app app             Application you are saving a snapshot (required)


please update the explantion of -n option to 
Namespace of the application you are restoring a snapshot
-f option to  Local path to restore tarball
-a option to  Application you are restoring a snapshot
-------------------------------------------------------------------
openshift@openshift-ubuntu:~/rhc$ rhc app -h
Usage: rhc app <action>
Creates  and controls an OpenShift application.  To see the list of all  applications use the rhc domain show command.  Note that delete is
not  reversible and will stop your application and then remove the  application and repo from the remote server. No local changes are made.
List of Actions
  force-stop         Stops all application processes
  show               Show information about an application
  status             Show status of an application's gears
  delete             Delete an application from the server

please update the explantion of status option to 
DEPRECATED  Please use 'rhc app show --state' instead
or  remove the status option.



Expected results:


Additional info:
Comment 1 Xiaoli Tian 2012-10-18 01:49:23 EDT
*** Bug 867637 has been marked as a duplicate of this bug. ***
Comment 2 Hiro Asari 2012-12-13 12:27:09 EST
Pull request here: https://github.com/openshift/rhc/pull/250
Comment 4 Rony Gong 2012-12-19 21:47:09 EST
Verified on devenv_2612
[qgong@localhost dev]$ rhc app -h
Usage: rhc app <action>

Creates and controls an OpenShift application.  To see the list of all applications use the rhc domain show command.  Note that delete is not reversible and
will stop your application and then remove the application and repo from the remote server. No local changes are made.

List of Actions
  restart            Restart the application
  start              Start the application
  show               Show information about an application
  force-stop         Stops all application processes
  status             DEPRECATED use 'show <app> --state' instead
  tidy               Clean out the application's logs and tmp directories and tidy up the git repo on the server
  stop               Stop the application
  create             Create an application
  reload             Reload the application's configuration
  delete             Delete an application from the server


[qgong@localhost dev]$ rhc app status -h
Usage: rhc app status <app> [--namespace namespace] [--app app]

DEPRECATED use 'show <app> --state' instead

Options for app status
  -n, --namespace namespace Namespace of the application belongs to
  -a, --app app             The name of the application you are getting information on

Global Options
  -l, --rhlogin LOGIN       OpenShift login
  -p, --password PASSWORD   OpenShift password
  --server NAME             An OpenShift server hostname (default: openshift.redhat.com)
  --timeout SECONDS         The timeout for operations


[qgong@localhost dev]$ rhc snapshot restore -h
Usage: rhc snapshot restore <application>

Restores a previously saved snapshot.

Options for snapshot restore
  -n, --namespace namespace Namespace of the application you are restoring a snapshot
  -f, --filepath filepath   Local path to restore tarball
  -a, --app app             Application of which you are restoring a snapshot (required)

Global Options
  -l, --rhlogin LOGIN       OpenShift login
  -p, --password PASSWORD   OpenShift password
  --server NAME             An OpenShift server hostname (default: openshift.redhat.com)
  --timeout SECONDS         The timeout for operations


[qgong@localhost dev]$ rhc app delete -h
Usage: rhc app delete <app> [--namespace namespace]

Deletes your application and all of its data from the server. Use with caution as this operation is permanent.

Options for app delete
  -n, --namespace namespace Namespace your application belongs to
  -b, --bypass              DEPRECATED Please use '--confirm'
  --confirm                 Deletes the application without prompting the user
  -a, --app name            The application you wish to delete

Global Options
  -l, --rhlogin LOGIN       OpenShift login
  -p, --password PASSWORD   OpenShift password
  --server NAME             An OpenShift server hostname (default: openshift.redhat.com)
  --timeout SECONDS         The timeout for operations

Note You need to log in before you can comment on or make changes to this bug.