Bug 865761 - qemu Segmentation fault while connect host using two spicec
qemu Segmentation fault while connect host using two spicec
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
x86_64 All
unspecified Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 07:11 EDT by yunpingzheng
Modified: 2014-03-03 19:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 04:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yunpingzheng 2012-10-12 07:11:32 EDT
Description of problem:
when connect guest using spicec , then connect using another spicec, the qemu will Segmentation fault 

Version-Release number of selected component (if applicable):
kvm-qemu-img-83-262.el5
kernel-2.6.18-342.el5
qspice-libs-0.3.0-54.el5_5.2
qspice-0.3.0-54.el5_5.2

How reproducible:
100%

Steps to Reproduce:
1. boot the guest 
2. connect the guest using spicec
3. connect the guest using another spicec

  
Actual results:
the qemu segmentation fault

Expected results:
the qemu should not segmentation fault.

Additional info:
host:
rhel 5
 kvm-qemu-img-83-262.el5
 kernel-2.6.18-342.el5
guest:
win2008r2 rhel6.3

qemu command:
 qemu-kvm -name 'vm1' \
 -monitor unix:'/tmp/monitor-humanmonitor1',server,nowait \
 -serial unix:'/tmp/serial-2',server,nowait \
 -drive file='/root/Rhel-6.3-64-virtio.qcow2',if=virtio,media=disk,boot=on,format=qcow2  \
 -net nic,vlan=0,model=virtio,macaddr='9a:0a:d1:95:f5:07' \
 -net tap,vlan=0,script=/root/qemu-ifup-switch -m 2048 \
 -smp 2,cores=1,threads=1,sockets=2 -cpu 'qemu64' \
 -drive file='/root/winutils.iso',media=cdrom \
 -soundhw ac97 -redir tcp:5001::10023 \
 -spice port=3101,ic=on,disable-ticketing \
 -qxl l -rtc-td-hack -M rhel5.6.0 -boot c  \
 -usbdevice tablet
Comment 1 yunpingzheng 2012-10-12 07:13:26 EDT
using -vga std/cirrus can reproduce. 

now i have the core dump file, i will analyse it latter.
Comment 2 Ronen Hod 2012-10-14 04:10:27 EDT
Closing, since it is probably not a regression, and too late for 5.9.

yunpingzheng,
It is worth checking with RHEL6.4 too.

Thanks, Ronen.
Comment 3 yunpingzheng 2012-10-14 22:06:45 EDT
hi Ronen
 in rhel 6.4 is ok.

Note You need to log in before you can comment on or make changes to this bug.