Bug 865777 - [abrt] simple-scan-3.6.0-1.fc18: ipConvert: Process /usr/bin/simple-scan was killed by signal 11 (SIGSEGV)
[abrt] simple-scan-3.6.0-1.fc18: ipConvert: Process /usr/bin/simple-scan was ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:0e7a84617048342279316469a7f...
:
: 872877 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 08:29 EDT by Stef Walter
Modified: 2012-11-06 11:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 11:39:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: var_log_messages (338 bytes, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: core_backtrace (793 bytes, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: environ (2.48 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: backtrace (82.59 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: cgroup (127 bytes, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: smolt_data (2.83 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: maps (95.24 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: dso_list (20.44 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: build_ids (7.97 KB, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: proc_pid_status (935 bytes, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details
File: open_fds (1022 bytes, text/plain)
2012-10-12 08:29 EDT, Stef Walter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1048691 None None None 2012-11-06 04:37:35 EST

  None (edit)
Description Stef Walter 2012-10-12 08:29:09 EDT
Description of problem:
Scanning a page from my HP LaserJet M1212nf MFP

Version-Release number of selected component:
simple-scan-3.6.0-1.fc18

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.15
backtrace_rating: 4
cmdline:        simple-scan
crash_function: ipConvert
kernel:         3.6.0-0.rc7.git0.1.fc18.x86_64

truncated backtrace:
:Thread no. 1 (7 frames)
: #0 ipConvert at ip/ipmain.c:791
: #1 get_ip_data at scan/sane/marvell.c:186
: #2 marvell_read at scan/sane/marvell.c:1004
: #3 scanner_do_read at scanner.c:7262
: #4 scanner_scan_thread at scanner.c:7862
: #5 _scanner_scan_thread_gthread_func at scanner.c:7876
: #6 g_thread_proxy at gthread.c:797
Comment 1 Stef Walter 2012-10-12 08:29:11 EDT
Created attachment 625954 [details]
File: var_log_messages
Comment 2 Stef Walter 2012-10-12 08:29:13 EDT
Created attachment 625955 [details]
File: core_backtrace
Comment 3 Stef Walter 2012-10-12 08:29:15 EDT
Created attachment 625956 [details]
File: environ
Comment 4 Stef Walter 2012-10-12 08:29:18 EDT
Created attachment 625957 [details]
File: limits
Comment 5 Stef Walter 2012-10-12 08:29:22 EDT
Created attachment 625958 [details]
File: backtrace
Comment 6 Stef Walter 2012-10-12 08:29:25 EDT
Created attachment 625960 [details]
File: cgroup
Comment 7 Stef Walter 2012-10-12 08:29:28 EDT
Created attachment 625961 [details]
File: smolt_data
Comment 8 Stef Walter 2012-10-12 08:29:32 EDT
Created attachment 625962 [details]
File: maps
Comment 9 Stef Walter 2012-10-12 08:29:35 EDT
Created attachment 625963 [details]
File: dso_list
Comment 10 Stef Walter 2012-10-12 08:29:38 EDT
Created attachment 625964 [details]
File: build_ids
Comment 11 Stef Walter 2012-10-12 08:29:40 EDT
Created attachment 625965 [details]
File: proc_pid_status
Comment 12 Stef Walter 2012-10-12 08:29:42 EDT
Created attachment 625966 [details]
File: open_fds
Comment 13 Adam Williamson 2012-11-03 18:31:36 EDT
Tried to scan a document. Using an HP MFP on the network, so this may be hplip stuff - xsane also crashes.

backtrace_rating: 4
Package: simple-scan-3.6.0-1.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 Adam Williamson 2012-11-03 18:40:46 EDT
Same model as Stef, I wonder if this has regressed? xsane also crashes in much the same code, https://bugzilla.redhat.com/show_bug.cgi?id=872877 . Assigning to hplip as I'm guessing that's where the problem is.
Comment 15 Adam Williamson 2012-11-03 18:41:31 EDT
*** Bug 872877 has been marked as a duplicate of this bug. ***
Comment 16 Adam Williamson 2012-11-03 18:45:08 EDT
From dmesg:

[40228.741011] simple-scan[20785]: segfault at 1133 ip 00007f4ce87f18fb sp 00007f4d014879b0 error 4 in libhpip.so.0.0.1[7f4ce87e7000+25000]
[40340.531327] traps: xsane[20890] general protection ip:7f8e5ddb48fb sp:7fff0e934300 error:0 in libhpip.so.0.0.1[7f8e5ddaa000+25000]
Comment 17 Jiri Popelka 2012-11-05 02:46:16 EST
Seems similar to bug #850826, which was resolved by updating the hp proprietary plugin. The only difference is that in this case we load /usr/share/hplip/scan/plugins/bb_marvell.so instead of bb_soapht.so

Can you both try to run hp-diagnose_plugin or hp-check-plugin (not sure what's the difference between them) to rule out this possibility ?
Comment 18 Adam Williamson 2012-11-05 12:54:11 EST
yeah, hp-diagnose_plugin says the proprietary plugin isn't installed, and after I re-installed it, scanning seems to work again. but it seems wrong for a working setup to break like this.

Note You need to log in before you can comment on or make changes to this bug.