Bug 865806 - pyOpenSSL-0.13-3.fc19.x86_64 pulls in latex2html and thus whole texlive
pyOpenSSL-0.13-3.fc19.x86_64 pulls in latex2html and thus whole texlive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pyOpenSSL (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 09:39 EDT by Petr Pisar
Modified: 2012-12-20 11:12 EST (History)
1 user (show)

See Also:
Fixed In Version: pyOpenSSL-0.13-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:12:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-10-12 09:39:15 EDT
pyOpenSSL-0.13-3.fc19.x86_64 started to run-runquire latex2html which needs weighty texlive. I cannot see reason why python binding to OpenSSL needs to process TeX files.

Please drop the dependency.
Comment 1 Petr Pisar 2012-10-12 09:40:56 EDT
# repoquery --requires pyOpenSSL 
libc.so.6(GLIBC_2.14)(64bit)
libcrypto.so.10()(64bit)
libcrypto.so.10(libcrypto.so.10)(64bit)
libpthread.so.0()(64bit)
libpython2.7.so.1.0()(64bit)
libssl.so.10()(64bit)
libssl.so.10(libssl.so.10)(64bit)
perl(Cwd)
perl(File::Basename)
perl(L2hos)
python(abi) = 2.7
rtld(GNU_HASH)
root@fedora-19:~ # repoquery --whatprovides 'perl(L2hos)'
latex2html-0:2008-7.fc18.noarch
Comment 2 Petr Pisar 2012-10-12 09:46:35 EDT
It's because some documentation (/usr/share/doc/pyOpenSSL-0.13/pyOpenSSL.l2h) is perl code.
Comment 3 Fedora Update System 2012-10-15 02:54:10 EDT
pyOpenSSL-0.13-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pyOpenSSL-0.13-4.fc18
Comment 4 Fedora Update System 2012-10-15 13:38:46 EDT
Package pyOpenSSL-0.13-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pyOpenSSL-0.13-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16134/pyOpenSSL-0.13-4.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 11:12:16 EST
pyOpenSSL-0.13-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.