Bug 865830 - f18b tc3 anaconda gets stuck (alt+tab works) when switching keyboard with the '-' 'minus' button from English to English
f18b tc3 anaconda gets stuck (alt+tab works) when switching keyboard with the...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
ia64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 10:35 EDT by Reartes Guillermo
Modified: 2012-11-22 23:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 23:51:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-10-12 10:35:08 EDT
Description of problem:

If one makes the mistake to switch from English to English, anaconda gets stuck.
Anaconda is not frozen, just stuck, alt+tab works (sadly it does nothing to get out of the situation), one can switch to another vt. Sadly, a reboot is needed.

Version-Release number of selected component (if applicable):
F18b tc3

How reproducible:
always

Steps to Reproduce:
1. enter keyboard, select (click) English
2. press '-' 'minus' button
3. select English from the list again.
4. When you press ADD, anaconda gets stuck.
  
Actual results:
stuck anaconda, reboot and try again. Alternatively do not make this
mistake :-)

Expected results:
an error dialog, a warning? or no error at all. The action itself
does not make sense, but anaconda should not get stuck.


Additional info:
I tried to add two English keyboards using the '+' 'pluss' button and there
was not problem whatsoever. Anaconda did the right thing, the problem is in the
minus button.
Comment 1 Chris Lumens 2012-10-12 10:48:26 EDT
Yeah, I see it too.  Looks like we're hitting a traceback, and then the traceback dialog never appears probably due to threading problems that we've got patches in the works for.
Comment 2 Vratislav Podzimek 2012-10-12 11:06:36 EDT
(In reply to comment #1)
> Yeah, I see it too.  Looks like we're hitting a traceback, and then the
> traceback dialog never appears probably due to threading problems that we've
> got patches in the works for.
In this case everything runs in one thread. The hang is probably caused by removing all layouts from X runtime configuration which may lead to killing X, hang or SIGSEGV (don't know the key determining the result).

Should be an easy fix.
Comment 3 Vratislav Podzimek 2012-10-12 11:15:31 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Yeah, I see it too.  Looks like we're hitting a traceback, and then the
> > traceback dialog never appears probably due to threading problems that we've
> > got patches in the works for.
> In this case everything runs in one thread. The hang is probably caused by
> removing all layouts from X runtime configuration which may lead to killing
> X, hang or SIGSEGV (don't know the key determining the result).
> 
> Should be an easy fix.
Oh man, I couldn't have been more wrong. It's yet another way to deadlock!
Comment 4 Vratislav Podzimek 2012-10-15 03:42:18 EDT
Patches for both the deadlock (hang) and the traceback sent to anaconda-patches list.
Comment 5 Vratislav Podzimek 2012-10-16 07:27:50 EDT
Pushed.
Comment 6 Fedora Update System 2012-10-16 23:07:47 EDT
anaconda-18.17-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.17-1.fc18
Comment 7 Fedora Update System 2012-10-17 13:28:54 EDT
Package anaconda-18.17-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.17-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16295/anaconda-18.17-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-10-17 22:36:48 EDT
anaconda-18.18-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.18-1.fc18
Comment 9 Fedora Update System 2012-10-18 11:28:42 EDT
Package anaconda-18.18-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.18-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16402/anaconda-18.18-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-10-19 21:32:37 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 11 Reartes Guillermo 2012-11-04 14:40:05 EST
I tried with F18b TC7 and it seems to be effectively fixed.
Comment 12 Adam Williamson 2012-11-22 23:51:39 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(confirmed fixed in Beta RC1)

Note You need to log in before you can comment on or make changes to this bug.