Bug 865930 - [abrt] libreoffice-core-3.5.6.2-5.fc17: GetArray: Process /usr/lib/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.6.2-5.fc17: GetArray: Process /usr/lib/libreoffic...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:66989e2d3905bf0d41a6a428b20...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 16:29 EDT by Benjamin Ariel Nava Martinez
Modified: 2013-05-09 06:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 06:11:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (3.90 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: environ (1.78 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: event_log (2.58 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: backtrace (42.04 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: cgroup (128 bytes, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: maps (60.40 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: dso_list (22.67 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: build_ids (8.41 KB, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: open_fds (334 bytes, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details
File: var_log_messages (317 bytes, text/plain)
2012-10-12 16:29 EDT, Benjamin Ariel Nava Martinez
no flags Details

  None (edit)
Description Benjamin Ariel Nava Martinez 2012-10-12 16:29:16 EDT
Description of problem:
Inserte una tabla de 5x6, despues escribi un poco de texto en la celda 2,3. Despues seleccione todo ese texto con Shitf+Fin y presione Supr. La tabla completa se borro, despues presione Ctrl+Z para deshacer y la tabla reaparecio, pero el texto de la celda 2,3 estaba arriba de la tabla y sin formato, luego seleccione ese texto y presione Supr e inmediatamente Writer se cerro.

Version-Release number of selected component:
libreoffice-core-3.5.6.2-5.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: GetArray
kernel:         3.5.5-2.fc17.i686

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 GetArray at /usr/src/debug/libreoffice-3.5.6.2/sw/inc/bparr.hxx:122
: #1 GetNodes at /usr/src/debug/libreoffice-3.5.6.2/sw/inc/node.hxx:718
: #2 SwNodeIndex::SwNodeIndex at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/docnode/ndindex.cxx:84
: #3 SwPosition::SwPosition at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/crsr/pam.cxx:83
: #4 SwPaM::SwPaM at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/crsr/pam.cxx:453
: #5 SwUndoInsert::UndoImpl at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/undo/unins.cxx:250
: #6 SwUndo::UndoWithContext at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/undo/undobj.cxx:253
: #7 SfxUndoManager::ImplUndo at /usr/src/debug/libreoffice-3.5.6.2/svl/source/undo/undo.cxx:807
: #8 SfxUndoManager::UndoWithContext at /usr/src/debug/libreoffice-3.5.6.2/svl/source/undo/undo.cxx:774
: #9 sw::UndoManager::impl_DoUndoRedo at /usr/src/debug/libreoffice-3.5.6.2/sw/source/core/undo/docundo.cxx:490
Comment 1 Benjamin Ariel Nava Martinez 2012-10-12 16:29:21 EDT
Created attachment 626222 [details]
File: core_backtrace
Comment 2 Benjamin Ariel Nava Martinez 2012-10-12 16:29:23 EDT
Created attachment 626223 [details]
File: environ
Comment 3 Benjamin Ariel Nava Martinez 2012-10-12 16:29:25 EDT
Created attachment 626224 [details]
File: event_log
Comment 4 Benjamin Ariel Nava Martinez 2012-10-12 16:29:28 EDT
Created attachment 626225 [details]
File: limits
Comment 5 Benjamin Ariel Nava Martinez 2012-10-12 16:29:31 EDT
Created attachment 626226 [details]
File: backtrace
Comment 6 Benjamin Ariel Nava Martinez 2012-10-12 16:29:33 EDT
Created attachment 626227 [details]
File: cgroup
Comment 7 Benjamin Ariel Nava Martinez 2012-10-12 16:29:35 EDT
Created attachment 626228 [details]
File: maps
Comment 8 Benjamin Ariel Nava Martinez 2012-10-12 16:29:39 EDT
Created attachment 626229 [details]
File: dso_list
Comment 9 Benjamin Ariel Nava Martinez 2012-10-12 16:29:41 EDT
Created attachment 626230 [details]
File: build_ids
Comment 10 Benjamin Ariel Nava Martinez 2012-10-12 16:29:43 EDT
Created attachment 626231 [details]
File: open_fds
Comment 11 Benjamin Ariel Nava Martinez 2012-10-12 16:29:45 EDT
Created attachment 626233 [details]
File: var_log_messages
Comment 12 David Tardon 2012-10-15 07:54:51 EDT
Google Translate says: "Insert a 5x6 table, then wrote some text in cell 2,3. Then select all the text and press End Shitf + Del. The entire table was cleared, then press Ctrl + Z to undo and table reappeared, but the text of the cell was 2.3 up from the table and plain, then select the text and press Delete and immediately Writer hill."
Comment 13 Benjamin Ariel Nava Martinez 2012-10-16 21:59:21 EDT
I can write the report in English if you want...
Comment 14 David Tardon 2012-10-19 06:06:57 EDT
Please do. Thanks.
Comment 15 Benjamin Ariel Nava Martinez 2013-01-05 17:26:33 EST
Ok:

Description of problem:
I inserted a 5x6 table, then I wrote some text inside cell 2,3 (row 2, column 3).
Then I selected all that text with Shitf+End and pressed Del. The whole table was deleted, then I pressed Ctrl+Z to undo and the table reappeared, but the text inside 2,3 now was one line over the table and without format, then I selected that text and pressed Del and Writer immediately closed.
Comment 16 Caolan McNamara 2013-02-06 04:30:50 EST
caolanm->mstahl: I can't reproduce this problem. Is is undo related, so perhaps fixed by one of your undo fixes ? Does the stacktrace or gude to reproduction speak to you ?
Comment 17 Caolan McNamara 2013-05-09 06:11:25 EDT
I'm going to assume this is fixed in 3.6.5.2-5.fc18 because I can't reproduce it there.

Note You need to log in before you can comment on or make changes to this bug.