Bug 865938 - Request for unknown module key 'Fedora kernel signing key: c6fb6e1f2b79b50ab078f4d6b9fc9b2204a692a7' err -11
Request for unknown module key 'Fedora kernel signing key: c6fb6e1f2b79b50ab0...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 16:54 EDT by John Florian
Modified: 2012-10-16 16:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 16:04:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Florian 2012-10-12 16:54:50 EDT
Description of problem:
I'm seeing many instances of this message when running journalctl right after booting my custom spin of F18 Live.  This spin consists of only Fedora-provided kernel modules.

Version-Release number of selected component (if applicable):
kernel-3.6.1-1.fc18.i686

How reproducible:
always

Additional info:
It appears to happen for nearly every module loaded.  To wit:

# dmesg  | grep 'Request for unknown module key' | wc -l
28
# lsmod  | wc -l
27

I can easily reproduce it on demand using a trivial, non-required "guinea pig" module:

# dmesg --clear
# rmmod serio_raw 
# dmesg
# modprobe serio_raw
# dmesg
[ 7466.423328] Request for unknown module key 'Fedora kernel signing key: c6fb6e1f2b79b50ab078f4d6b9fc9b2204a692a7' err -11
Comment 1 Dave Jones 2012-10-16 15:54:59 EDT
full dmesg output please.
Comment 2 John Florian 2012-10-16 16:04:09 EDT
Not a bug.  My humble apologies for the noise and interruption.

The culprit was the RTC not being set correctly:

> [    3.591826] Loading module verification certificates
> [    3.601372] Cert Valid From: 2012-10-08 16:52:26
> [    3.610300] Cert Valid To: 2112-09-14 16:52:26
> [    3.618967] Now: 2003-01-01 00:02:42
> [    3.626830] X.509: Cert c6fb6e1f2b79b50ab078f4d6b9fc9b2204a692a7 is not
> yet valid
> [    3.643056] MODSIGN: Problem loading in-kernel X.509 certificate (-129)
> [    3.654414] registered taskstats version 1
> [    3.664906]   Magic number: 3:0:0
> [    3.673116] rtc_cmos 00:04: setting system clock to 2003-01-01 00:02:44
> UTC (1041379364)

Note You need to log in before you can comment on or make changes to this bug.