Bug 865985 - FSError: mount failed: (32, 'mount: wrong fs type, bad option, bad superblock on /dev/sda3,\n missing codepage or helper program, or other error\n In some cases useful info is found in syslog - try\n dmesg | tail or so')
FSError: mount failed: (32, 'mount: wrong fs type, bad option, bad superblock...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:fa7d03e6441373c023ad14bfcf1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 00:00 EDT by Itamar Reis Peixoto
Modified: 2013-03-10 23:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 10:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (5.25 KB, text/plain)
2012-10-13 00:00 EDT, Itamar Reis Peixoto
no flags Details
File: anaconda-tb (558.62 KB, text/plain)
2012-10-13 00:00 EDT, Itamar Reis Peixoto
no flags Details
File: product (6 bytes, text/plain)
2012-10-13 00:00 EDT, Itamar Reis Peixoto
no flags Details
File: type (9 bytes, text/plain)
2012-10-13 00:00 EDT, Itamar Reis Peixoto
no flags Details
File: environ (764 bytes, text/plain)
2012-10-13 00:00 EDT, Itamar Reis Peixoto
no flags Details

  None (edit)
Description Itamar Reis Peixoto 2012-10-13 00:00:13 EDT
Version-Release number of selected component:
anaconda-18.14

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.i686

description:
:The following was filed automatically by anaconda:
:anaconda 18.14 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 630, in mount
:    raise FSError("mount failed: %s" % e)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 860, in setup
:    return self.mount(**kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2732, in mountFilesystems
:    chroot=rootPath)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1642, in mountFilesystems
:    readOnly=readOnly, skipRoot=skipRoot)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 218, in turnOnFilesystems
:    skipRoot=False)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 101, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 87, in run
:    threading.Thread.run(self, *args, **kwargs)
:FSError: mount failed: (32, 'mount: wrong fs type, bad option, bad superblock on /dev/sda3,\n       missing codepage or helper program, or other error\n       In some cases useful info is found in syslog - try\n       dmesg | tail or so')
Comment 1 Itamar Reis Peixoto 2012-10-13 00:00:18 EDT
Created attachment 626405 [details]
File: ifcfg.log
Comment 2 Itamar Reis Peixoto 2012-10-13 00:00:30 EDT
Created attachment 626406 [details]
File: anaconda-tb
Comment 3 Itamar Reis Peixoto 2012-10-13 00:00:33 EDT
Created attachment 626407 [details]
File: product
Comment 4 Itamar Reis Peixoto 2012-10-13 00:00:35 EDT
Created attachment 626408 [details]
File: type
Comment 5 Itamar Reis Peixoto 2012-10-13 00:00:37 EDT
Created attachment 626409 [details]
File: environ
Comment 6 Chris Lumens 2012-10-16 10:13:17 EDT
Check the end of your syslog.  You have an awful lot of errors in there indicating either kernel or hardware failure.  Unfortunately, there's not really anything anaconda can do about this.
Comment 7 Clyde E. Kunkel 2012-10-18 09:37:32 EDT
Just got this same error with the Fedora-18B-smoketest DVD on a 4 disk VM.  I don't know how to attach logs from a VM and the error reporter doesn't forward logs when it finds a duplicate bz.  That said, syslog reports:

ERR kernel: [  xxx.yyyyyy] EXT4-fs (sdb1): VFS: Can't find ext4 file system

Was trying to created btrfs /, /home and /data and ext4 /boot and standard swap. Error occurred after clicking start installation.

Should this bz be reopened?

How do you preserve logs from a VM install attempt?

Will try to see if can duplicate.
Comment 8 Clyde E. Kunkel 2012-10-18 10:09:28 EDT
Bz 867895 created successfully after retrying.  I did modify the VM, tho, by adding an existing ext4 partition to save logs on.  That partition was not selected as part of the custom partitioning attempt.
Comment 9 Clyde E. Kunkel 2012-11-20 17:05:17 EST
This bz comes up in a F17 VM when VDisks are created from ext4 partitions and you delete them in the partitioner and then create / and /home on btrfs, swap and boot on ext4.

Isn't this a bug?  I have seen it several times in the VM world.
Comment 10 Clyde E. Kunkel 2012-11-30 21:39:28 EST
Still getting this error with F18Beta in a VM.

Here is my entry in 867895 where I was trying confirm that error:

OK, so here goes.  Tried to recreate as best I could with F18Beta, but I probably did not exactly duplicate the VM I used originally.  I got an error, but bugzilla said it was a duplicate, bz 865985, which I do get frequently with VMs.  That bug was closed as not a bug due to what looked like hardware problems.  I wonder?  I kept the logs.

Here is what I tried with the 4 disk VM:  selected standard partitioning and custom.  Created /, /home and /data as standard partitions then customized them to btrfs with redundancy and performance.  swap and /boot were standard.  No errors found by the partitioner.  After entering the root password the error occurred.

Do you want the logs?
Comment 11 qdyiyeqing 2013-03-10 23:57:54 EDT
I have the same problem.
And I don't know what happened to my hard driver?
It's difficult to think it's not a bug.

Note You need to log in before you can comment on or make changes to this bug.