Bug 866072 - fedora mirror system is flawed; deletes previous version(s) when receiving newer version
fedora mirror system is flawed; deletes previous version(s) when receiving ne...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 14:05 EDT by udo
Modified: 2012-10-14 10:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 05:33:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2012-10-13 14:05:52 EDT
Description of problem:
fedora mirror system is flawed; deletes previous version(s) when receiving newer version
this means we cannot downgrade easily when a bug is discovered.
in this case we get downgraded to Firefox 12 coming form 16 with a xulrunner related symbol issue.
This is perhaps not a yum bug but I cannot choose the mirror system as a subject.


Version-Release number of selected component (if applicable):


How reproducible:
Upgrade to latest firefox and thunderbird. see ul symbol error when runnign FF or TB from terminal window
do dowgrade in yum.
see resulting version.

  
Actual results:
back to the stone age.

Expected results:
latest major version minus one.

Additional info:
Comment 1 Elad Alfassa 2012-10-14 05:33:17 EDT
Not a yum bug. I suggest you bring up this topic in the fedora-devel mailing list if you think it's important.

https://lists.fedoraproject.org/



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 udo 2012-10-14 05:40:54 EDT
And of course the only user-accessible process with loggin is unusable for deepgoing stuff like the one I mentioned.
We can't forward it, we close it and we're done.
So much for progress.
You don't even mention whether you agree or not.
I even wrote "This is perhaps not a yum bug but I cannot choose the mirror system as a subject." so that flaw is also a bug.

FIX the stuff instead of referring elsewhere.
If you don't fix it, why have bugzilla handle it?
Why release it?
I.O.W. what is the role in such cases of Red Hat?
Comment 3 Elad Alfassa 2012-10-14 06:26:57 EDT
Clarification: I don't speak for Red Hat, Fedora Project or the yum developers. My comments are my own opinion and not anyone else's.

This is simply not the right place to report this issue.

If you want the right people to hear you out, you should report the issue in the right place. You need the rel-eng team and not the yum team. Therefore I closed the bug, yum has already too much unrelated bugs lying around and these makes developer work harder and might cause them to miss actual bugs between the piles of unrelated issues people blame yum for.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 udo 2012-10-14 06:36:29 EDT
It is at least weird if not abhorring that RH doesn not have a usable policy of mirroring the files while Fedora is in it's 17th release.
If you suggest that I should tell them then the issue-reporting system is shot as well.
I do not care who's opinion I read, with all respect, but I want to have stuff changed so that we simply downgrade 1 major version.
Is that so hard?

You make it look like it is.
Comment 5 udo 2012-10-14 06:38:02 EDT
If such a mirror-fix is not implemented then I'd like to be able to have yum only install packages that have been available for XX time.
That time is the margin in which I hope other will see the issues that otherwise I'd encounter.
Comment 6 Tim Lauridsen 2012-10-14 10:52:58 EDT
(In reply to comment #5)
> If such a mirror-fix is not implemented then I'd like to be able to have yum
> only install packages that have been available for XX time.
> That time is the margin in which I hope other will see the issues that
> otherwise I'd encounter.

Just install the yum-plugin-local, it will put any package download by yum into a local repo and keep them there even if they are removed from the upstream repositories.

If you are using the updates testing repository, you will spot issuës with updates before they it the main updates repository, and you will be able to downgrade to the latest stable release in the updates and the distro release version in the fedora repository.

Maybe you should find a more humble tone, if you want other people to change something, you don't start to offend them :)
Most of Fedora community work are done by volunteers, they don't get paid to do it, so you can't demand anything of them and offending these people will just make close there ears.
Comment 7 udo 2012-10-14 10:59:22 EDT
It is not about the tone, it is about the message.
Furthermore I am not a native speaker and quite flabbergasted that the mirroring system is so simplistic indeed.
The trigger for my uproar was that both firefox and thunderbird were missing a dependency to the nspr package.
It is absurd that this can slip through given the maturity of both products.
See https://bugzilla.redhat.com/show_bug.cgi?id=866057 for that issue.

I did not have a solution then.
So the workaround was of course to downgrade.
But instead of going from FF 16 to 15 IO went from 16 to 12.
Everywhere I looked on teh net: no more copies of FF 15 x86_64 rpm for Fedora...
This made me think about the absurdity in that fact.
Not even a simple plan B was possible.
Because in this case we have a rapid version cycle of FF, but what about if it were another tool? Being less compatible with it's previous version?
This a big risk and asking for disaster.
Of course just for the users, but you understand what I mean.

The solution to run a repo at home is one way; I'll see how that works.

Note You need to log in before you can comment on or make changes to this bug.