This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 866083 - [abrt] yum-3.4.3-29.fc17: re.py:242:_compile:error: bad character range
[abrt] yum-3.4.3-29.fc17: re.py:242:_compile:error: bad character range
Status: CLOSED DUPLICATE of bug 864294
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:cbc7f197111276880403a21e55f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 15:47 EDT by Luya Tshimbalanga
Modified: 2012-10-15 02:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 02:59:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (33 bytes, text/plain)
2012-10-13 15:47 EDT, Luya Tshimbalanga
no flags Details
File: environ (3.15 KB, text/plain)
2012-10-13 15:47 EDT, Luya Tshimbalanga
no flags Details
File: smolt_data (3.11 KB, text/plain)
2012-10-13 15:47 EDT, Luya Tshimbalanga
no flags Details
File: core_backtrace (1018 bytes, text/plain)
2012-10-13 15:47 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2012-10-13 15:47:13 EDT
Description of problem:
Testing yum command with bracket [...] like yum list installed [blender]

Version-Release number of selected component:
yum-3.4.3-29.fc17

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.15
cmdline:        /usr/bin/python /usr/bin/yum list installed [gnome-do]
kernel:         3.6.1-1.fc17.x86_64

backtrace:
:re.py:242:_compile:error: bad character range
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 319, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 144, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/yumcommands.py", line 546, in doCommand
:    ypl = base.returnPkgLists(extcmds, installed_available=highlight)
:  File "/usr/share/yum-cli/cli.py", line 1265, in returnPkgLists
:    ignore_case=True)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2630, in doPackageLists
:    ignore_case=ic):
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 627, in returnPackages
:    rpats = self._compile_patterns(patterns, ignore_case)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 552, in _compile_patterns
:    ret.append((qpat, re.compile(fnmatch.translate(pat), re.I)))
:  File "/usr/lib64/python2.7/re.py", line 190, in compile
:    return _compile(pattern, flags)
:  File "/usr/lib64/python2.7/re.py", line 242, in _compile
:    raise error, v # invalid expression
:error: bad character range
:
:Local variables in innermost frame:
:cachekey: (<type 'str'>, '[gnome-do]\\Z(?ms)', 2)
:pattern: '[gnome-do]\\Z(?ms)'
:p: None
:flags: 2
:key: ('[gnome-do]\\Z(?ms)', 2)
:v: error('bad character range',)
Comment 1 Luya Tshimbalanga 2012-10-13 15:47:16 EDT
Created attachment 626642 [details]
File: dso_list
Comment 2 Luya Tshimbalanga 2012-10-13 15:47:17 EDT
Created attachment 626643 [details]
File: environ
Comment 3 Luya Tshimbalanga 2012-10-13 15:47:19 EDT
Created attachment 626644 [details]
File: smolt_data
Comment 4 Luya Tshimbalanga 2012-10-13 15:47:20 EDT
Created attachment 626645 [details]
File: core_backtrace
Comment 5 Zdeněk Pavlas 2012-10-15 02:59:56 EDT
The backtrace is fixed upstream, however we search for package literally named '[gnome-do]', so there's no match.

*** This bug has been marked as a duplicate of bug 864294 ***

Note You need to log in before you can comment on or make changes to this bug.