Bug 866105 - systemd drops to emergency shell when wrong password for cryptsetup is entered during boot
systemd drops to emergency shell when wrong password for cryptsetup is entere...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 21:55 EDT by Mukundan Ragavan
Modified: 2013-03-07 19:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 19:24:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file created by journalctl command on dracut shell. (96.82 KB, text/plain)
2012-10-13 21:55 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2012-10-13 21:55:25 EDT
Created attachment 626728 [details]
log file created by journalctl command on dracut shell.

Description of problem:

I installed F18 beta TC3 using netinstall to a hard disk encrypted using anaconda during installation.

When I boot the installed system, if I make a mistake in entering the passphrase to decrypt the hard disk, the booting process is terminated and emergency shell appears.


[DEPEND] Dependency failed for basic system
dracut #

I get a message that says to type "journalctl" to see the log files.

Version-Release number of selected component (if applicable):
systemd-194-1.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start the installed system. Installation should be done on a encrypted hard disk (/, /home and swap).
2. Enter the wrong passphrase to decrypt the hard disk for booting to continue.
3. When the "enter password" prompt appears, try to enter the passphrase again or hit F2.
  
Actual results:
booting drops to emergency shell.

Expected results:
prompt for passphrase again.

Additional info:
journalctl created log file is attached.
Comment 1 Lennart Poettering 2013-03-07 11:22:18 EST
Is this still a problem with current F18?

If so, does this happen immediately when the password is entered incorrectly? Or is there some timeout?
Comment 2 Mukundan Ragavan 2013-03-07 11:30:54 EST
Yes. It is still a problem. But, unlike before, it does not drop in to an emergency shell on first attempt. I am able to enter the wrong password up to three times before it drops to emergency shell.

As for the timeout - if I happen to enter the wrong password multiple times, it drops to an emergency shell after a small time interval - typically, the delay is only as long as the time taken for password authentication.
Comment 3 Lennart Poettering 2013-03-07 19:24:00 EST
(In reply to comment #2)
> Yes. It is still a problem. But, unlike before, it does not drop in to an
> emergency shell on first attempt. I am able to enter the wrong password up
> to three times before it drops to emergency shell.

That's intended. You can reconfigure the number of tries with the tries= option in crypttab(5).

> As for the timeout - if I happen to enter the wrong password multiple times,
> it drops to an emergency shell after a small time interval - typically, the
> delay is only as long as the time taken for password authentication.

That's something that can be controlled with the x-systemd.device-timeout=0 which anaconda should set by default for all file systems originating in crypto disks. That's tracked in bug 861123.

Since there's nothing else in this bug report, will close now.

Note You need to log in before you can comment on or make changes to this bug.