Bug 866143 - [rhevm] - Upgrade - No Roll-Back when Upgrade 3.0 to 3.1 fails
[rhevm] - Upgrade - No Roll-Back when Upgrade 3.0 to 3.1 fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Alex Lourie
Tareq Alayan
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 06:46 EDT by David Botzer
Modified: 2014-01-13 19:04 EST (History)
9 users (show)

See Also:
Fixed In Version: si24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rhevm-old (48.91 KB, application/x-gzip)
2012-10-14 06:46 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-10-14 06:46:33 EDT
Created attachment 626885 [details]
rhevm-old

Description of problem:
Upgrade 3.0 to 3.1 fails for some reason (e.x open db connections)
As a result of that - /etc/rhevm & /etc/pki/rhevm folders are changed to rhevm-old
-- cannot rerun rhevm-upgrade

Version-Release number of selected component (if applicable):
3.0 ic157
3.1 si20

How reproducible:
always

Steps to Reproduce:
1.install rhevm30+ETL+reports
2.upgrade rhevm-setup
3.rhevm-upgrade - will fail on a BZ that setup doesnt asks to close connections
4.Close DB connections (restart ETL, postgresql)
4.Rerun of rhevm-upgrade Fails
  
Actual results:
/etc/rhevm & /etc/pki/rhevm folders are changed to rhevm-old

Expected results:
Rollback should return state

Additional info:
Comment 3 Tareq Alayan 2012-11-13 13:39:12 EST
couldn't reproduce.
DB backup-ed and renamed.

Note You need to log in before you can comment on or make changes to this bug.